summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciek Borzecki2018-06-12 10:30:53 +0200
committerMaciek Borzecki2018-06-12 10:30:53 +0200
commit3a09341629054a3e28aa12b610c259a00ce7bb51 (patch)
tree93dcc65dd0fe168fdc9101372cff77ee162f995b
parenta14e8aecfd34e5ecc8aa62549192af4c1e7e0098 (diff)
downloadaur-3a09341629054a3e28aa12b610c259a00ce7bb51.tar.gz
snapd: use budled release pacakage, bump to 2.33-2
Users have reported issues with govendor trying to get the dependencies. Avoid this by using the source tarball with bundled vendor dependencies. Signed-off-by: Maciek Borzecki <maciek.borzecki@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 6 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc60efc83512..d5d54f1f2b05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = snapd
pkgdesc = Service and tools for management of snap packages.
pkgver = 2.33
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/snapcore/snapd
install = snapd.install
arch = x86_64
@@ -21,8 +21,8 @@ pkgbase = snapd
conflicts = snap-confine
options = !strip
options = emptydirs
- source = snapd-2.33.tar.gz::https://github.com/snapcore/snapd/archive/2.33.tar.gz
- sha256sums = 7d75bb3589086381aec6f6039f1dddcadd79d35e3a544b32701e86636baa97c2
+ source = snapd-2.33.tar.xz::https://github.com/snapcore/snapd/releases/download/2.33/snapd_2.33.vendor.tar.xz
+ sha256sums = 35f429194398461e74e13aaec47307754adcafc1571044d625fcf561537c103c
pkgname = snapd
diff --git a/PKGBUILD b/PKGBUILD
index c21eaacc8b9b..951aa3147772 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Service and tools for management of snap packages."
depends=('squashfs-tools' 'libseccomp' 'libsystemd')
optdepends=('bash-completion: bash completion support')
pkgver=2.33
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/snapcore/snapd"
license=('GPL3')
@@ -16,8 +16,8 @@ makedepends=('git' 'go' 'go-tools' 'libseccomp' 'libcap' 'systemd' 'xfsprogs' 'p
conflicts=('snap-confine')
options=('!strip' 'emptydirs')
install=snapd.install
-source=("$pkgname-$pkgver.tar.gz::https://github.com/snapcore/${pkgname}/archive/$pkgver.tar.gz")
-sha256sums=('7d75bb3589086381aec6f6039f1dddcadd79d35e3a544b32701e86636baa97c2')
+source=("$pkgname-$pkgver.tar.xz::https://github.com/snapcore/${pkgname}/releases/download/${pkgver}/${pkgname}_${pkgver}.vendor.tar.xz")
+sha256sums=('35f429194398461e74e13aaec47307754adcafc1571044d625fcf561537c103c')
_gourl=github.com/snapcore/snapd
@@ -46,11 +46,6 @@ build() {
./mkversion.sh $pkgver-$pkgrel
- # Use get-deps.sh provided by upstream to fetch go dependencies using the
- # godeps tool and dependencies.tsv (maintained upstream).
- cd "$GOPATH/src/${_gourl}"
- XDG_CONFIG_HOME="$srcdir" ./get-deps.sh
-
gobuild="go build -buildmode=pie"
gobuild_static="go build -buildmode=pie -ldflags=-extldflags=-static"
# Build/install snap and snapd