summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciek Borzecki2018-10-25 13:48:00 +0200
committerMaciek Borzecki2018-10-25 13:49:36 +0200
commit4e43dedbe20c36b6ab4d3d40906363c459a84845 (patch)
treeffafc35f520b8935ad186a748a19a8311588fad7
parent65c3593eb09efd98050cfa186d7070b9facb0372 (diff)
downloadaur-4e43dedbe20c36b6ab4d3d40906363c459a84845.tar.gz
upgpkg: snapd 2.36-1, enable AppArmor
New upstream release. This is the first version of snapd with AppArmor enabled on Arch. Signed-off-by: Maciek Borzecki <maciek.borzecki@gmail.com>
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ffecc7b2c9a..d18ab223f846 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = snapd
pkgdesc = Service and tools for management of snap packages.
- pkgver = 2.35.4
+ pkgver = 2.36
pkgrel = 1
url = https://github.com/snapcore/snapd
install = snapd.install
@@ -14,6 +14,7 @@ pkgbase = snapd
makedepends = systemd
makedepends = xfsprogs
makedepends = python-docutils
+ makedepends = apparmor
depends = squashfs-tools
depends = libseccomp
depends = libsystemd
@@ -21,8 +22,8 @@ pkgbase = snapd
conflicts = snap-confine
options = !strip
options = emptydirs
- source = snapd-2.35.4.tar.xz::https://github.com/snapcore/snapd/releases/download/2.35.4/snapd_2.35.4.vendor.tar.xz
- sha256sums = bd6caaa446f8bc22ebdc80d524704b74bec4f3976034742eaa2f73a6fd8c4713
+ source = snapd-2.36.tar.xz::https://github.com/snapcore/snapd/releases/download/2.36/snapd_2.36.vendor.tar.xz
+ sha256sums = 65a54a4e21419394859063e926a012f07c04a9bfb1146a28a3f48c9221331d86
pkgname = snapd
diff --git a/PKGBUILD b/PKGBUILD
index 2c986effd050..c6040e1928c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,17 +7,17 @@ pkgname=snapd
pkgdesc="Service and tools for management of snap packages."
depends=('squashfs-tools' 'libseccomp' 'libsystemd')
optdepends=('bash-completion: bash completion support')
-pkgver=2.35.4
+pkgver=2.36
pkgrel=1
arch=('x86_64')
url="https://github.com/snapcore/snapd"
license=('GPL3')
-makedepends=('git' 'go' 'go-tools' 'libseccomp' 'libcap' 'systemd' 'xfsprogs' 'python-docutils')
+makedepends=('git' 'go' 'go-tools' 'libseccomp' 'libcap' 'systemd' 'xfsprogs' 'python-docutils' 'apparmor')
conflicts=('snap-confine')
options=('!strip' 'emptydirs')
install=snapd.install
source=("$pkgname-$pkgver.tar.xz::https://github.com/snapcore/${pkgname}/releases/download/${pkgver}/${pkgname}_${pkgver}.vendor.tar.xz")
-sha256sums=('bd6caaa446f8bc22ebdc80d524704b74bec4f3976034742eaa2f73a6fd8c4713')
+sha256sums=('65a54a4e21419394859063e926a012f07c04a9bfb1146a28a3f48c9221331d86')
_gourl=github.com/snapcore/snapd
@@ -76,7 +76,7 @@ build() {
--prefix=/usr \
--libexecdir=/usr/lib/snapd \
--with-snap-mount-dir=/var/lib/snapd/snap \
- --disable-apparmor \
+ --enable-apparmor \
--enable-nvidia-biarch \
--enable-merged-usr
make $MAKEFLAGS
@@ -119,6 +119,7 @@ package() {
# pre-create directories
install -dm755 "$pkgdir/var/lib/snapd/snap"
install -dm755 "$pkgdir/var/cache/snapd"
+ install -dm755 "$pkgdir/var/lib/snapd/apparmor"
install -dm755 "$pkgdir/var/lib/snapd/assertions"
install -dm755 "$pkgdir/var/lib/snapd/desktop/applications"
install -dm755 "$pkgdir/var/lib/snapd/device"
@@ -137,9 +138,6 @@ package() {
install -dm700 "$pkgdir/var/lib/snapd/cache"
make -C cmd install DESTDIR="$pkgdir/"
- # move snapd-generator to systemd generators
- install -dm755 "$pkgdir/usr/lib/systemd/system-generators"
- mv "$pkgdir/usr/lib/snapd/snapd-generator" "$pkgdir/usr/lib/systemd/system-generators/"
# Install man file
mkdir -p "$pkgdir/usr/share/man/man1"
@@ -158,6 +156,4 @@ package() {
rm -fv "$pkgdir/usr/lib/snapd/snapd.core-fixup.sh"
rm -fv "$pkgdir/usr/bin/ubuntu-core-launcher"
rm -fv "$pkgdir/usr/lib/snapd/system-shutdown"
- # apparmor bits
- rm -rfv "$pkgdir"/var/lib/snapd/apparmor
}