summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciek Borzecki2020-08-12 15:42:51 +0200
committerMaciek Borzecki2020-08-12 15:42:51 +0200
commit917b75cd8a235b69c29b2daed92bfbf187d53775 (patch)
treee23d7fcf79fadcbaa430cd5c9f76d874592baa9b
parent4f80a5c2b675ef621a449708c0c4689628c941cb (diff)
downloadaur-917b75cd8a235b69c29b2daed92bfbf187d53775.tar.gz
upgpkg: snapd 2.45.3.1-2
Fix build with go 1.15. Signed-off-by: Maciek Borzecki <maciek.borzecki@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f810d8c32ef..c58f3122a5a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = snapd
pkgdesc = Service and tools for management of snap packages.
pkgver = 2.45.3.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/snapcore/snapd
install = snapd.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index f55fddb8acad..bee21e8f9adf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ depends=('squashfs-tools' 'libseccomp' 'libsystemd' 'apparmor')
optdepends=('bash-completion: bash completion support'
'xdg-desktop-portal: desktop integration')
pkgver=2.45.3.1
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://github.com/snapcore/snapd"
license=('GPL3')
@@ -62,7 +62,7 @@ build() {
# is not exactly the same as -ldflags "-extldflags '-foo'" use the array trick
# to pass exactly what we want
flags=(-buildmode=pie -ldflags "-s -extldflags '$LDFLAGS'")
- staticflags=(-buildmode=pie -ldflags "-s -extldflags '$LDFLAGS -static'")
+ staticflags=(-buildmode=pie -ldflags "-s -linkmode external -extldflags '$LDFLAGS -static'")
# Build/install snap and snapd
go build "${flags[@]}" -o "$srcdir/go/bin/snap" "${_gourl}/cmd/snap"
go build "${flags[@]}" -o "$srcdir/go/bin/snapd" "${_gourl}/cmd/snapd"