summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciek Borzecki2018-07-05 09:45:04 +0200
committerMaciek Borzecki2018-07-05 09:45:04 +0200
commitb7ba4ada0ccb1cd6be257213ef4e85482ec63287 (patch)
treeae4cd92e607d71b6fe0e1d0370233447bc30513a
parent590313fe3f3538b1701aa431ed4f5b975ca4aab8 (diff)
downloadaur-b7ba4ada0ccb1cd6be257213ef4e85482ec63287.tar.gz
snapd: backport improved distro detection patch, bump pkgrel
Backport a patch improving distro detection on other Arch like systems that also use this package, eg. Antegros. Signed-off-by: Maciek Borzecki <maciek.borzecki@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--0001-dirs-improve-distro-detection-for-Antegros.patch47
-rw-r--r--0001-dirs-improve-identification-of-Arch-Linux-like-syste.patch30
-rw-r--r--PKGBUILD8
4 files changed, 54 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 103084ae2077..91964ec569a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = snapd
pkgdesc = Service and tools for management of snap packages.
pkgver = 2.33.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/snapcore/snapd
install = snapd.install
arch = x86_64
@@ -22,9 +22,9 @@ pkgbase = snapd
options = !strip
options = emptydirs
source = snapd-2.33.1.tar.xz::https://github.com/snapcore/snapd/releases/download/2.33.1/snapd_2.33.1.vendor.tar.xz
- source = 0001-dirs-improve-identification-of-Arch-Linux-like-syste.patch
+ source = 0001-dirs-improve-distro-detection-for-Antegros.patch
sha256sums = ac36fc0093c3eb3eaf2158db3ad3a26114903724d6cb98b7068fe45d6b440d94
- sha256sums = 8f3d31705c1d32f5b199c0794f03acf40e2eb8e0c54fb5cb49831fdbfe5aaf80
+ sha256sums = a86152415ff57cd9d4e6bf306fb9a81dc26a762fdbb0785f815eec243a50a377
pkgname = snapd
diff --git a/0001-dirs-improve-distro-detection-for-Antegros.patch b/0001-dirs-improve-distro-detection-for-Antegros.patch
new file mode 100644
index 000000000000..384c035c6a38
--- /dev/null
+++ b/0001-dirs-improve-distro-detection-for-Antegros.patch
@@ -0,0 +1,47 @@
+From ce723673d8823adf2248771a7ea129622054a045 Mon Sep 17 00:00:00 2001
+Message-Id: <ce723673d8823adf2248771a7ea129622054a045.1530775180.git.maciej.zenon.borzecki@canonical.com>
+From: Maciej Borzecki <maciej.zenon.borzecki@canonical.com>
+Date: Thu, 5 Jul 2018 07:28:41 +0200
+Subject: [PATCH] dirs: improve distro detection for Antegros
+
+Previous attempt to use ID_LIKE=archlinux for detecting Arch Linux like distros
+failed. It seems that there is no consensus about using ID/ID_LIKE.
+
+For reference, this is what is contained in /etc/os-release for Arch like
+distros:
+
+- Arch:
+ ID=arch
+ ID_LIKE=archlinux
+
+- Manjaro (no ID_LIKE):
+ ID=manjaro
+
+- Antegros:
+ ID="antergos"
+ ID_LIKE="arch"
+
+Relying on ID_LIKE seems to have little sense since there seems to be no
+agreement as to what that variable should be set to.
+
+Signed-off-by: Maciej Borzecki <maciej.zenon.borzecki@canonical.com>
+---
+ dirs/dirs.go | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/dirs/dirs.go b/dirs/dirs.go
+index 16a3a7a4f32c5e830254d160f395520505d6dd62..c37733ff250ab049aa18f60a54dd768dbe2b04d7 100644
+--- a/dirs/dirs.go
++++ b/dirs/dirs.go
+@@ -179,7 +179,7 @@ func SetRootDir(rootdir string) {
+ }
+ GlobalRootDir = rootdir
+
+- if release.DistroLike("fedora", "arch", "manjaro") {
++ if release.DistroLike("fedora", "arch", "manjaro", "antegros") {
+ SnapMountDir = filepath.Join(rootdir, "/var/lib/snapd/snap")
+ } else {
+ SnapMountDir = filepath.Join(rootdir, defaultSnapMountDir)
+--
+2.18.0
+
diff --git a/0001-dirs-improve-identification-of-Arch-Linux-like-syste.patch b/0001-dirs-improve-identification-of-Arch-Linux-like-syste.patch
deleted file mode 100644
index 66074c0aab24..000000000000
--- a/0001-dirs-improve-identification-of-Arch-Linux-like-syste.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 043ea8a4831975373e1cb5c63dc09ee5609f5d36 Mon Sep 17 00:00:00 2001
-Message-Id: <043ea8a4831975373e1cb5c63dc09ee5609f5d36.1529666554.git.maciej.zenon.borzecki@canonical.com>
-From: Maciej Borzecki <maciej.zenon.borzecki@canonical.com>
-Date: Fri, 22 Jun 2018 12:34:30 +0200
-Subject: [PATCH] dirs: improve identification of Arch Linux like systems
-
-Arch Linux derivatives correctly set ID_LIKE=archlinux but we use 'arch' in our
-detection (which is only set by Arch as ID=arch).
-
-Signed-off-by: Maciej Borzecki <maciej.zenon.borzecki@canonical.com>
----
- dirs/dirs.go | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/dirs/dirs.go b/dirs/dirs.go
-index df4c028083c16c6abfa7438a5b11459e9dcc9b07..2e84ae962665f97e1bc2312993a89b1a8bc58bbf 100644
---- a/dirs/dirs.go
-+++ b/dirs/dirs.go
-@@ -178,7 +178,7 @@ func SetRootDir(rootdir string) {
- }
- GlobalRootDir = rootdir
-
-- if release.DistroLike("fedora", "arch", "manjaro") {
-+ if release.DistroLike("fedora", "archlinux", "manjaro") {
- SnapMountDir = filepath.Join(rootdir, "/var/lib/snapd/snap")
- } else {
- SnapMountDir = filepath.Join(rootdir, defaultSnapMountDir)
---
-2.17.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 644bc2816690..c405e4fc0a8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Service and tools for management of snap packages."
depends=('squashfs-tools' 'libseccomp' 'libsystemd')
optdepends=('bash-completion: bash completion support')
pkgver=2.33.1
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/snapcore/snapd"
license=('GPL3')
@@ -17,9 +17,9 @@ conflicts=('snap-confine')
options=('!strip' 'emptydirs')
install=snapd.install
source=("$pkgname-$pkgver.tar.xz::https://github.com/snapcore/${pkgname}/releases/download/${pkgver}/${pkgname}_${pkgver}.vendor.tar.xz"
- '0001-dirs-improve-identification-of-Arch-Linux-like-syste.patch')
+ '0001-dirs-improve-distro-detection-for-Antegros.patch')
sha256sums=('ac36fc0093c3eb3eaf2158db3ad3a26114903724d6cb98b7068fe45d6b440d94'
- '8f3d31705c1d32f5b199c0794f03acf40e2eb8e0c54fb5cb49831fdbfe5aaf80')
+ 'a86152415ff57cd9d4e6bf306fb9a81dc26a762fdbb0785f815eec243a50a377')
_gourl=github.com/snapcore/snapd
@@ -35,7 +35,7 @@ prepare() {
mkdir -p "$(dirname "$GOPATH/src/${_gourl}")"
ln --no-target-directory -fs "$srcdir/$pkgname-$pkgver" "$GOPATH/src/${_gourl}"
- patch -Np1 -i "$srcdir/0001-dirs-improve-identification-of-Arch-Linux-like-syste.patch"
+ patch -Np1 -i "$srcdir/0001-dirs-improve-distro-detection-for-Antegros.patch"
}
build() {