summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciek Borzecki2018-07-23 10:01:49 +0200
committerMaciek Borzecki2018-07-23 10:03:21 +0200
commitf925f256a563721162a9bfaf71461528bc1cc7ef (patch)
treef08b8927e44035b17f95ad0d0d6fb3cfe9940a74
parent709605edc28dfcf70130a1b2e4b45028f21bb822 (diff)
downloadaur-f925f256a563721162a9bfaf71461528bc1cc7ef.tar.gz
snapd: update to 2.34.2
- update to the latest release - drop Antergos patch, already merged upstream - linux-hardened has AppArmor enabled now, do not snapd.apparmor.service in case someone wants to use it
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--antergos-detection.patch74
3 files changed, 8 insertions, 88 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed67dcd819bb..8652322ff7c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = snapd
pkgdesc = Service and tools for management of snap packages.
- pkgver = 2.33.1
- pkgrel = 3
+ pkgver = 2.34.2
+ pkgrel = 1
url = https://github.com/snapcore/snapd
install = snapd.install
arch = x86_64
@@ -21,10 +21,8 @@ pkgbase = snapd
conflicts = snap-confine
options = !strip
options = emptydirs
- source = snapd-2.33.1.tar.xz::https://github.com/snapcore/snapd/releases/download/2.33.1/snapd_2.33.1.vendor.tar.xz
- source = antergos-detection.patch
- sha256sums = ac36fc0093c3eb3eaf2158db3ad3a26114903724d6cb98b7068fe45d6b440d94
- sha256sums = 0c801960629d42b3704c20d9bd4464aa5b7f1a67378c4baf8339154e601489d7
+ source = snapd-2.34.2.tar.xz::https://github.com/snapcore/snapd/releases/download/2.34.2/snapd_2.34.2.vendor.tar.xz
+ sha256sums = b184601402ac81c5b897466bc49f399d202e6b779b4a6a36b080d27f211c5a34
pkgname = snapd
diff --git a/PKGBUILD b/PKGBUILD
index 3756e2f0abf0..1d9f7b9440c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@ pkgname=snapd
pkgdesc="Service and tools for management of snap packages."
depends=('squashfs-tools' 'libseccomp' 'libsystemd')
optdepends=('bash-completion: bash completion support')
-pkgver=2.33.1
-pkgrel=3
+pkgver=2.34.2
+pkgrel=1
arch=('x86_64')
url="https://github.com/snapcore/snapd"
license=('GPL3')
@@ -16,10 +16,8 @@ makedepends=('git' 'go' 'go-tools' 'libseccomp' 'libcap' 'systemd' 'xfsprogs' 'p
conflicts=('snap-confine')
options=('!strip' 'emptydirs')
install=snapd.install
-source=("$pkgname-$pkgver.tar.xz::https://github.com/snapcore/${pkgname}/releases/download/${pkgver}/${pkgname}_${pkgver}.vendor.tar.xz"
- 'antergos-detection.patch')
-sha256sums=('ac36fc0093c3eb3eaf2158db3ad3a26114903724d6cb98b7068fe45d6b440d94'
- '0c801960629d42b3704c20d9bd4464aa5b7f1a67378c4baf8339154e601489d7')
+source=("$pkgname-$pkgver.tar.xz::https://github.com/snapcore/${pkgname}/releases/download/${pkgver}/${pkgname}_${pkgver}.vendor.tar.xz")
+sha256sums=('b184601402ac81c5b897466bc49f399d202e6b779b4a6a36b080d27f211c5a34')
_gourl=github.com/snapcore/snapd
@@ -34,8 +32,6 @@ prepare() {
# above describes.
mkdir -p "$(dirname "$GOPATH/src/${_gourl}")"
ln --no-target-directory -fs "$srcdir/$pkgname-$pkgver" "$GOPATH/src/${_gourl}"
-
- patch -Np1 -i "$srcdir/antergos-detection.patch"
}
build() {
diff --git a/antergos-detection.patch b/antergos-detection.patch
deleted file mode 100644
index aed880cc10da..000000000000
--- a/antergos-detection.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From ce723673d8823adf2248771a7ea129622054a045 Mon Sep 17 00:00:00 2001
-Message-Id: <ce723673d8823adf2248771a7ea129622054a045.1530775180.git.maciej.zenon.borzecki@canonical.com>
-From: Maciej Borzecki <maciej.zenon.borzecki@canonical.com>
-Date: Thu, 5 Jul 2018 07:28:41 +0200
-Subject: [PATCH] dirs: improve distro detection for Antegros
-
-Previous attempt to use ID_LIKE=archlinux for detecting Arch Linux like distros
-failed. It seems that there is no consensus about using ID/ID_LIKE.
-
-For reference, this is what is contained in /etc/os-release for Arch like
-distros:
-
-- Arch:
- ID=arch
- ID_LIKE=archlinux
-
-- Manjaro (no ID_LIKE):
- ID=manjaro
-
-- Antegros:
- ID="antergos"
- ID_LIKE="arch"
-
-Relying on ID_LIKE seems to have little sense since there seems to be no
-agreement as to what that variable should be set to.
-
-Signed-off-by: Maciej Borzecki <maciej.zenon.borzecki@canonical.com>
----
- dirs/dirs.go | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/dirs/dirs.go b/dirs/dirs.go
-index 16a3a7a4f32c5e830254d160f395520505d6dd62..c37733ff250ab049aa18f60a54dd768dbe2b04d7 100644
---- a/dirs/dirs.go
-+++ b/dirs/dirs.go
-@@ -179,7 +179,7 @@ func SetRootDir(rootdir string) {
- }
- GlobalRootDir = rootdir
-
-- if release.DistroLike("fedora", "arch", "manjaro") {
-+ if release.DistroLike("fedora", "arch", "manjaro", "antegros") {
- SnapMountDir = filepath.Join(rootdir, "/var/lib/snapd/snap")
- } else {
- SnapMountDir = filepath.Join(rootdir, defaultSnapMountDir)
---
-2.18.0
-
-From 24ff45db682acb8265a98cd6b2c87453f8b6a99e Mon Sep 17 00:00:00 2001
-Message-Id: <24ff45db682acb8265a98cd6b2c87453f8b6a99e.1530787202.git.maciej.zenon.borzecki@canonical.com>
-From: Maciej Borzecki <maciej.zenon.borzecki@canonical.com>
-Date: Thu, 5 Jul 2018 11:04:05 +0200
-Subject: [PATCH] dirs: fix antergos typo
-
-Signed-off-by: Maciej Borzecki <maciej.zenon.borzecki@canonical.com>
----
- dirs/dirs.go | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/dirs/dirs.go b/dirs/dirs.go
-index c37733ff250ab049aa18f60a54dd768dbe2b04d7..2087fdf2baef19ee8f2553cced964b4010001a09 100644
---- a/dirs/dirs.go
-+++ b/dirs/dirs.go
-@@ -179,7 +179,7 @@ func SetRootDir(rootdir string) {
- }
- GlobalRootDir = rootdir
-
-- if release.DistroLike("fedora", "arch", "manjaro", "antegros") {
-+ if release.DistroLike("fedora", "arch", "manjaro", "antergos") {
- SnapMountDir = filepath.Join(rootdir, "/var/lib/snapd/snap")
- } else {
- SnapMountDir = filepath.Join(rootdir, defaultSnapMountDir)
---
-2.18.0
-