summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMitchell Renouf2018-10-17 18:51:47 -0230
committerMitchell Renouf2018-10-17 18:51:47 -0230
commit4abcfc4bc922510a3b45d92edc50114129f29cce (patch)
tree82d91aa44278410c5d7ed39246955e6cf1e30a29
downloadaur-4abcfc4bc922510a3b45d92edc50114129f29cce.tar.gz
inital commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD29
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..798e5211d8c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = snapd-glib
+ pkgdesc = Library to allow GLib/Qt based applications access to snapd, the daemon that controls Snaps
+ pkgver = 1.44
+ pkgrel = 1
+ url = https://github.com/snapcore/snapd-glib
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = libsoup
+ makedepends = json-glib
+ makedepends = qt5-declarative
+ makedepends = qt5-base
+ makedepends = glib2
+ makedepends = gtk-doc
+ makedepends = autoconf
+ makedepends = pkg-config
+ makedepends = automake
+ makedepends = libtool
+ depends = libsoup
+ depends = json-glib
+ provides = snapd-glib
+ conflicts = snapd-glib
+ options = !strip
+ options = emptydirs
+ source = https://github.com/snapcore/snapd-glib/archive/1.44.tar.gz
+ sha256sums = ecc87b677bd7f8a64fab7b98deb35a37f8d6d1e986eb62f5b0a6142cc89b2e1e
+
+pkgname = snapd-glib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52192c471a89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mitchell Renouf <mitchellarenouf@gmail.com>
+
+pkgbase=snapd-glib
+pkgname=snapd-glib
+pkgdesc="Library to allow GLib/Qt based applications access to snapd, the daemon that controls Snaps"
+depends=( 'libsoup' 'json-glib')
+pkgver=1.44
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/snapcore/snapd-glib"
+license=('GPL3')
+makedepends=('git' 'libsoup' 'json-glib' 'qt5-declarative' 'qt5-base' 'glib2' 'gtk-doc' 'autoconf' 'pkg-config' 'automake' 'libtool')
+conflicts=($pkgbase)
+options=('!strip' 'emptydirs')
+source=("https://github.com/snapcore/$pkgbase/archive/$pkgver.tar.gz")
+sha256sums=('ecc87b677bd7f8a64fab7b98deb35a37f8d6d1e986eb62f5b0a6142cc89b2e1e')
+
+provides=($pkgbase)
+
+build() {
+ cd "$pkgbase-$pkgver"
+ ./autogen.sh --disable-silent-rules --enable-gtk-doc --prefix=/usr
+ make $MAKEFLAGS
+}
+
+package_snapd-glib() {
+ cd "$pkgbase-$pkgver"
+ make install DESTDIR="$pkgdir"
+}