summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMitchell Renouf2018-10-17 15:07:12 -0230
committerMitchell Renouf2018-10-17 15:07:12 -0230
commit461a3e31c4b3412975d74f5fb9d55bf349f3f136 (patch)
tree6afbbebef67878c09c20c9ba7f49692413a11db9
downloadaur-461a3e31c4b3412975d74f5fb9d55bf349f3f136.tar.gz
inital commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD36
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de37fa14e854
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = snapd-glib-git
+ pkgdesc = Library to allow GLib/Qt based applications access to snapd, the daemon that controls Snaps
+ pkgver = 1.44.r6.g44ae271
+ pkgrel = 1
+ url = https://github.com/snapcore/snapd-glib
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = libsoup
+ makedepends = json-glib
+ makedepends = qt5-declarative
+ makedepends = qt5-base
+ makedepends = glib2
+ makedepends = gtk-doc
+ makedepends = autoconf
+ makedepends = pkg-config
+ makedepends = automake
+ makedepends = libtool
+ depends = libsoup
+ depends = json-glib
+ provides = snapd-glib
+ conflicts = snapd-glib
+ options = !strip
+ options = emptydirs
+ source = git+https://github.com/snapcore/snapd-glib.git
+ sha256sums = SKIP
+
+pkgname = snapd-glib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb378b17e322
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Mitchell Renouf <mitchellarenouf@gmail.com>
+
+_pkgbase=snapd-glib
+pkgbase=snapd-glib-git
+pkgname=snapd-glib-git
+pkgdesc="Library to allow GLib/Qt based applications access to snapd, the daemon that controls Snaps"
+depends=( 'libsoup' 'json-glib')
+pkgver=1.44.r6.g44ae271
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/snapcore/snapd-glib"
+license=('GPL3')
+makedepends=('git' 'libsoup' 'json-glib' 'qt5-declarative' 'qt5-base' 'glib2' 'gtk-doc' 'autoconf' 'pkg-config' 'automake' 'libtool')
+conflicts=($_pkgbase)
+options=('!strip' 'emptydirs')
+source=("git+https://github.com/snapcore/$_pkgbase.git")
+sha256sums=('SKIP')
+
+provides=($_pkgbase)
+
+
+pkgver() {
+ cd "$srcdir/snapd-glib"
+ git describe --tag | sed -r 's/([^-]*-g)/r\1/; s/-/./g'
+}
+
+build() {
+ cd "$_pkgbase"
+ ./autogen.sh --disable-silent-rules --enable-gtk-doc --prefix=/usr
+ make $MAKEFLAGS
+}
+
+package_snapd-glib-git() {
+ cd "$_pkgbase"
+ make install DESTDIR="$pkgdir"
+}