summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBitals2023-11-05 12:29:40 +0400
committerBitals2023-11-05 12:29:40 +0400
commit26233d5b9635ac105120ba279cd2ad6d07347a3d (patch)
tree91d5d3f85669760557c0a46f7c9e0fce71128c03
parent3a43d1b011f5f6418dd0f88fbfd77bca04311911 (diff)
downloadaur-26233d5b9635ac105120ba279cd2ad6d07347a3d.tar.gz
7.0.3
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 941257c6a15b..fad32affa755 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = snapgene
pkgdesc = Software for plasmid mapping, primer design, and restriction site analysis
- pkgver = 7.0.2
+ pkgver = 7.0.3
pkgrel = 1
url = http://www.snapgene.com/products/snapgene/
arch = x86_64
license = custom
- source = https://cdn.snapgene.com/downloads/SnapGene/7.x/7.0/7.0.2/snapgene_7.0.2_linux.rpm
- sha512sums = 517fb1812508d9457a0f75e746a3923e72ed314df5ba8ddf504220442ad9d08dd9a8b14c7d078306ba68f0b391f1f1ce08551e29394876fa3883267cce3b21fe
+ source = https://cdn.snapgene.com/downloads/SnapGene/7.x/7.0/7.0.3/snapgene_7.0.3_linux.rpm
+ sha512sums = a8d3bf97ef93a97b92e40cfa1b00e0ff4814536f6cda51147ceab009dc794b7fbf1b9f65667ced8d111774d8381e49620a659aea082de893422e6881bf6d19e7
pkgname = snapgene
diff --git a/.gitignore b/.gitignore
index 3860bceb9747..589af85af62f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
snapgene_*_linux.rpm
+snapgene-*.pkg.tar
PKGBUILD
.vscode
diff --git a/PKGBUILD b/PKGBUILD
index 88981788158a..2a0a73e82c50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Based on snapgene-viewer package by Antony Lee <anntzer dot lee at gmail dot com>
# Maintainer: Bitals <me at bitals dot xyz>
-# Co-Maintainer: Matthijs Tadema <M dot J dot Tadema at gmail dot com>
-# Co-Maintainer: Lorenzo Gaifas <brisvag at gmail dot com>
+# Contributor: Matthijs Tadema <M dot J dot Tadema at gmail dot com>
+# Contributor: Lorenzo Gaifas <brisvag at gmail dot com>
pkgname=snapgene
-pkgver=7.0.2
+pkgver=7.0.3
_pkgver_major=$(cut -d '.' -f 1 <<<"$pkgver")
_pkgver_major_middle=$(cut -d '.' -f 1-2 <<<"$pkgver")
pkgrel=1
@@ -12,8 +12,8 @@ arch=('x86_64')
url='http://www.snapgene.com/products/snapgene/'
license=('custom')
# A valid licence is required to use the full version of snapgene
-source=("https://cdn.snapgene.com/downloads/SnapGene/"$_pkgver_major".x/"$_pkgver_major_middle"/"$pkgver"/snapgene_"$pkgver"_linux.rpm")
-sha512sums=('517fb1812508d9457a0f75e746a3923e72ed314df5ba8ddf504220442ad9d08dd9a8b14c7d078306ba68f0b391f1f1ce08551e29394876fa3883267cce3b21fe')
+source=("https://cdn.snapgene.com/downloads/SnapGene/"$_pkgver_major".x/"$_pkgver_major_middle"/"$pkgver"/"$pkgname"_"$pkgver"_linux.rpm")
+sha512sums=('a8d3bf97ef93a97b92e40cfa1b00e0ff4814536f6cda51147ceab009dc794b7fbf1b9f65667ced8d111774d8381e49620a659aea082de893422e6881bf6d19e7')
package() {
cd "$pkgdir"