summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Lee2016-02-27 21:03:23 -0800
committerAntony Lee2016-02-27 21:03:23 -0800
commitccda81ac102e07927d73f8a451a05faf36a46a9f (patch)
treeea7b2d040bea8344825c0bc2bbcb2eb7d55265a7
downloadaur-ccda81ac102e07927d73f8a451a05faf36a46a9f.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
-rw-r--r--snapgene-viewer.install13
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a966c34b55ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Feb 28 04:57:19 UTC 2016
+pkgbase = snapgene-viewer
+ pkgdesc = Software for plasmid mapping, primer design, and restriction site analysis
+ pkgver = 3.0.3
+ pkgrel = 1
+ url = http://www.snapgene.com/products/snapgene_viewer/
+ install = snapgene-viewer.install
+ arch = x86_64
+ license = custom
+ makedepends = rpmextract
+ depends = shared-mime-info
+ source = snapgene_viewer_3.0.3_linux.rpm::http://www.snapgene.com/products/snapgene_viewer/download.php?&majorRelease=3.0&minorRelease=3.0.3&os=linux_rpm
+ md5sums = cc41ad744b999af732befdddabe45f1a
+
+pkgname = snapgene-viewer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f440888df8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
+pkgname=snapgene-viewer
+pkgver=3.0.3
+pkgrel=1
+pkgdesc='Software for plasmid mapping, primer design, and restriction site analysis'
+arch=('x86_64')
+url='http://www.snapgene.com/products/snapgene_viewer/'
+license=('custom')
+depends=('shared-mime-info')
+makedepends=('rpmextract')
+install="$pkgname.install"
+source=('snapgene_viewer_3.0.3_linux.rpm::http://www.snapgene.com/products/snapgene_viewer/download.php?&majorRelease=3.0&minorRelease=3.0.3&os=linux_rpm')
+md5sums=('cc41ad744b999af732befdddabe45f1a')
+
+# Some shared libraries could be stripped out and installed as dependencies
+# instead. However, directly calling the snapgene-viewer binary currently
+# segfaults, so some care is needed.
+
+package() {
+ cd "$pkgdir"
+ rpmextract.sh "$srcdir/snapgene_viewer_3.0.3_linux.rpm"
+ mkdir "$pkgdir/usr/bin"
+ cat <<'EOF' >"$pkgdir/usr/bin/snapgene-viewer"
+#!/bin/sh
+# Snapgene Viewer is not localized and genbank exports are invalid in other
+# locales, so we just set LANG=C.
+LANG=C /opt/gslbiotech/snapgene-viewer/snapgene-viewer.sh
+EOF
+ chmod a+x "$pkgdir/usr/bin/snapgene-viewer"
+}
diff --git a/snapgene-viewer.install b/snapgene-viewer.install
new file mode 100644
index 000000000000..4cb57e3beeb5
--- /dev/null
+++ b/snapgene-viewer.install
@@ -0,0 +1,13 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &>/dev/null
+ update-mime-database usr/share/mime &>/dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+post_remove() {
+ post_install "$1"
+}