summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2020-12-20 20:12:07 +1100
committerMatthew Gamble2020-12-20 20:12:07 +1100
commite01bfde43ed38e43608ee7f119e9b51d06badebb (patch)
tree906d6d8de52e1cbd63915211c40daf88f2aa077d
downloadaur-e01bfde43ed38e43608ee7f119e9b51d06badebb.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
-rw-r--r--config.example.json3
4 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bf306d98541
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = snapidy
+ pkgdesc = Alternative web client for Snapcast
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/djmattyg007/snapidy
+ arch = any
+ license = GPL3
+ license = MIT
+ makedepends = zip
+ noextract = snapidy-1.0.1.zip
+ source = https://github.com/djmattyg007/snapidy/releases/download/1.0.1/snapidy-1.0.1.zip
+ source = config.example.json
+ sha256sums = 2648293374020eba11721e36cc6948eb50ad2de5158a3e7eadb0c6dc5fdc8d1f
+ sha256sums = cef91057cd29a645a5fd7878b0845e77c192d028261837b6cb833f3963d8a07c
+
+pkgname = snapidy
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0f563530c9f2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.pkg.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e19f83a44953
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+
+pkgname="snapidy"
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Alternative web client for Snapcast"
+url="https://github.com/djmattyg007/snapidy"
+license=("GPL3" "MIT")
+arch=("any")
+makedepends=("zip")
+source=(
+ "https://github.com/djmattyg007/snapidy/releases/download/${pkgver}/snapidy-${pkgver}.zip"
+ "config.example.json"
+)
+noextract=(
+ "snapidy-${pkgver}.zip"
+)
+sha256sums=(
+ "2648293374020eba11721e36cc6948eb50ad2de5158a3e7eadb0c6dc5fdc8d1f"
+ "cef91057cd29a645a5fd7878b0845e77c192d028261837b6cb833f3963d8a07c"
+)
+
+package() {
+ install -dm755 "${pkgdir}/usr/share/snapidy/dist"
+ cd "${pkgdir}/usr/share/snapidy/dist"
+ unzip "${srcdir}/snapidy-${pkgver}.zip"
+ chmod -R u+rwX,go+rX "${pkgdir}/usr/share/snapidy/dist"
+
+ install -dm755 "${pkgdir}/etc/webapps/snapidy"
+ ln -s "../../../../etc/webapps/snapidy/config.json" "${pkgdir}/usr/share/snapidy/dist/config.json"
+ install -Dm644 "${srcdir}/config.example.json" "${pkgdir}/usr/share/snapidy/config.example.json"
+ install -Dm644 "${srcdir}/config.example.json" "${pkgdir}/etc/webapps/snapidy/config.example.json"
+}
diff --git a/config.example.json b/config.example.json
new file mode 100644
index 000000000000..1ecbc9f2df15
--- /dev/null
+++ b/config.example.json
@@ -0,0 +1,3 @@
+{
+ "wsUrl": "wss://snapcast.example.com:1780/jsonrpc"
+}