summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-10-26 23:07:04 +0800
committermaz-12015-10-26 23:07:04 +0800
commitbeea25fbfbac2b7fedbfe21eae6d20a06423b3dd (patch)
tree1b4614c209eea389812e2c46e62f3c2821ee2031
downloadaur-beea25fbfbac2b7fedbfe21eae6d20a06423b3dd.tar.gz
init
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD31
-rwxr-xr-xsnapper-gui.desktop8
-rw-r--r--snapper-gui.install24
-rw-r--r--snapper-gui.svg37
5 files changed, 129 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85a40f532de0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = snapper-gui-git
+ pkgdesc = Gui for snapper, a tool of managing snapshots of Btrfs subvolumes and LVM volumes
+ pkgver = 1.7.0.r6.g97c6ae3
+ pkgrel = 1
+ url = https://github.com/ricardomv/snapper-gui
+ install = snapper-gui.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = python3
+ depends = gtk3
+ depends = python-dbus
+ depends = python-gobject
+ depends = python-setuptools
+ depends = gtksourceview3
+ depends = snapper-git
+ optdepends = gksu: Access snapper-gui from application menu under GTK-base DE
+ optdepends = kdesu: Access snapper-gui from application menu under KDE
+ provides = snapper-gui
+ conflicts = snapper-gui
+ source = snapper-gui-git::git+https://github.com/ricardomv/snapper-gui.git
+ source = snapper-gui.svg
+ source = snapper-gui.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = snapper-gui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf06d65b695e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ilias Stamatis <stamatis.iliass at gmail dot com>
+# Contributor: Panagiotis Mavrogiorgos (pmav99) <> (gmail)
+
+pkgname=snapper-gui-git
+pkgver=1.7.0.r6.g97c6ae3
+pkgrel=1
+pkgdesc="Gui for snapper, a tool of managing snapshots of Btrfs subvolumes and LVM volumes"
+arch=(any)
+url="https://github.com/ricardomv/snapper-gui"
+license=('GPL2')
+depends=('python3' 'gtk3' 'python-dbus' 'python-gobject' 'python-setuptools' 'gtksourceview3' 'snapper-git')
+optdepends=('gksu: Access snapper-gui from application menu under GTK-base DE'
+ 'kdesu: Access snapper-gui from application menu under KDE')
+makedepends=('git')
+provides=('snapper-gui')
+conflicts=('snapper-gui')
+install=snapper-gui.install
+source=("${pkgname}::git+https://github.com/ricardomv/snapper-gui.git" "snapper-gui.svg" "snapper-gui.desktop")
+sha256sums=('SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 "${srcdir}/snapper-gui.svg" "${pkgdir}/usr/share/pixmaps/snapper-gui.svg"
+ install -Dm755 "${srcdir}/snapper-gui.desktop" "${pkgdir}/usr/share/applications/snapper-gui.desktop"
+}
diff --git a/snapper-gui.desktop b/snapper-gui.desktop
new file mode 100755
index 000000000000..d0398be56e9d
--- /dev/null
+++ b/snapper-gui.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Snapper GUI
+GenericName=Snapper GUI
+Comment=Managing BTRFS and LVM snapshots
+Exec=[ -f /usr/bin/gksu ] && exec gksu snapper-gui || exec kdesu snapper-gui
+Icon=snapper-gui
+Categories=System;Filesystem;
diff --git a/snapper-gui.install b/snapper-gui.install
new file mode 100644
index 000000000000..a7136fa7c6af
--- /dev/null
+++ b/snapper-gui.install
@@ -0,0 +1,24 @@
+
+post_install() {
+ echo ">>>"
+ echo ">>> You must create a default config with snapper cli named root first."
+ echo ">>> Run 'snapper -c root create-config /' as root"
+ echo ">>>"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ /bin/true
+}
+
+post_remove() {
+ /bin/true
+}
+op=$1
+shift
+
+$op $*
+
diff --git a/snapper-gui.svg b/snapper-gui.svg
new file mode 100644
index 000000000000..bce4c68353b3
--- /dev/null
+++ b/snapper-gui.svg
@@ -0,0 +1,37 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+<svg
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ version="1.0"
+ width="215"
+ height="200"
+ viewBox="-0.628 -0.612 512 438"
+ id="svg2"
+ xml:space="preserve">
+ <defs
+ id="defs4">
+
+
+
+
+
+
+
+
+
+
+ </defs>
+ <g
+ transform="matrix(2.20098,0,0,2.20098,-303.0895,-264.0106)"
+ id="g1911"><path
+ d="M 357.0625,174.03125 C 357.0625,175.54325 357.06525,176.74475 357.28125,177.96875 C 357.06525,180.20076 356.5665,182.942 356.0625,185.75 C 355.3425,188.34201 354.31775,190.8115 353.09375,193.1875 C 352.08575,194.91551 350.88025,196.632 349.65625,198 C 347.71224,200.088 345.679,202.022 343.375,203.75 C 341.359,205.47901 339.07575,207.007 336.84375,208.375 C 334.46775,209.959 331.64225,211.32625 328.90625,212.40625 C 326.81826,213.41426 324.60425,214.27725 322.15625,214.78125 C 319.42024,215.64525 316.452,216.14 313.5,216.5 C 311.412,216.716 309.3285,216.86275 307.3125,216.71875 C 306.59249,216.71875 306.23775,216.34775 306.09375,215.84375 C 306.09374,215.26775 306.0775,214.985 306.4375,214.625 C 306.9415,213.905 307.4525,213.2635 307.8125,212.6875 L 319.1875,199.09375 L 277.21875,202.53125 C 273.90675,202.89125 270.65575,202.9075 267.34375,202.1875 C 264.60776,201.82751 262.0295,201.1615 259.4375,199.9375 C 256.48549,198.5695 253.03075,196.853 249.71875,195.125 L 236.8125,229.8125 C 232.85249,230.89249 228.67875,232.05725 224.71875,233.28125 C 225.58275,232.92125 221.2765,234.50975 216.8125,236.09375 C 212.1325,237.82175 208.971,239.1755 205.875,240.6875 C 199.827,243.6395 193.97875,246.96525 188.21875,250.78125 C 185.33875,252.65325 182.1775,254.8835 178.9375,257.1875 C 176.9935,258.69951 174.9195,260.431 172.6875,262.375 L 166.25,268.5625 C 163.00999,271.6585 159.91675,275.3185 157.46875,279.0625 C 158.69275,279.42251 159.94175,279.79625 161.09375,280.15625 C 161.45375,280.30024 161.95525,280.51225 162.53125,280.65625 C 165.41125,281.52024 167.4935,282.03 169.4375,282.75 C 170.80549,283.25401 172.16325,283.746 173.53125,284.25 C 176.69925,285.68999 179.798,286.84125 182.75,288.28125 C 183.902,288.78526 185.11975,289.31125 186.34375,290.03125 C 186.84774,290.31926 187.58975,290.67125 188.09375,291.03125 C 188.09375,291.24726 188.21875,291.231 188.21875,291.375 C 188.21875,291.375 188.4375,291.534 188.4375,291.75 C 188.5815,291.89401 188.59375,292.09375 188.59375,292.09375 C 188.59375,292.59775 188.2255,292.981 187.9375,293.125 C 185.8495,293.629 183.61925,293.981 181.53125,294.125 C 178.21925,294.701 175.12725,295.3425 172.03125,296.0625 C 168.86325,296.7105 165.7645,297.8045 162.8125,298.8125 C 160.7965,299.31651 158.48475,300.155 156.46875,300.875 C 154.52475,301.595 152.6655,302.246 150.9375,302.75 C 150.43351,302.96599 150.0625,303.10875 150.0625,303.46875 C 150.0625,303.82874 150.4185,303.96875 150.5625,303.96875 C 150.70651,303.96874 150.71875,303.96875 150.71875,303.96875 L 197.09375,307.28125 C 197.59775,307.28126 198.08975,307.4375 198.59375,307.4375 C 199.45775,307.4375 200.3235,307.28125 201.1875,307.28125 C 204.13949,306.92126 206.93925,306.2145 209.53125,305.0625 C 212.98725,303.4785 215.9515,301.40725 218.6875,299.03125 C 221.13551,296.58326 223.34675,294.111 225.21875,291.375 C 226.94676,288.783 228.1795,285.97375 229.1875,283.09375 C 230.2675,280.50175 230.92125,277.558 231.28125,274.75 C 231.64125,272.51799 231.78125,270.14775 231.78125,267.84375 C 243.30125,266.83575 254.54925,265.459 265.78125,263.875 C 282.77324,260.923 299.52275,255.102 315.21875,246.75 C 319.53876,244.518 323.8865,242.29175 328.0625,239.84375 C 330.7985,238.33175 333.89175,236.38825 336.84375,234.15625 C 339.43575,232.06825 341.86175,230.03775 344.09375,228.09375 C 346.54175,225.86176 348.91475,223.27675 351.21875,220.46875 C 355.32276,215.50075 358.28425,209.5955 360.15625,203.1875 C 360.87625,200.30749 361.371,197.346 361.875,194.25 C 361.875,193.17 362.09375,192.1615 362.09375,190.9375 C 362.09375,189.5695 361.894,187.993 361.75,186.625 C 361.24601,183.81701 360.508,181.217 359.5,178.625 C 358.78001,177.113 357.9265,175.54325 357.0625,174.03125 z M 185.1875,261.5625 C 188.4275,261.5625 191.09375,264.31301 191.09375,267.625 C 191.09375,271.009 188.4275,273.6875 185.1875,273.6875 C 181.9475,273.6875 179.28124,271.00901 179.28125,267.625 C 179.28125,264.313 181.9475,261.56251 185.1875,261.5625 z "
+ transform="translate(-0.628,-0.612)"
+ id="path16" /><path
+ d="M 313.596,285.732 C 296.244,295.956 277.092,302.724 257.004,305.676 L 243.036,306.828 L 228.78,307.692 L 213.732,307.548 C 217.692,305.1 221.292,302.22 224.46,298.908 L 227.556,295.308 C 230.148,291.996 232.236,288.54 233.604,284.724 C 234.252,282.276 234.828,280.044 235.332,277.668 L 236.196,272.124 L 251.172,270.54 L 262.908,269.028 L 270.828,267.804 C 275.364,266.94 279.828,265.716 284.364,264.348 L 298.836,259.164 L 310.068,254.124 L 321.516,248.436 L 332.244,242.532 L 340.668,236.844 L 351.396,226.836 L 359.388,215.892 L 358.884,220.068 C 356.796,233.532 351.756,246.492 344.34,258.084 C 339.3,266.076 332.892,272.772 325.476,277.956 L 321.516,280.764 L 313.596,285.732 z "
+ id="path20" /><path
+ d="M 341.82,154.692 C 338.507,152.316 335.052,150.228 331.236,148.5 L 269.172,122.724 L 268.164,122.22 C 267.948,122.22 267.804,122.076 267.588,122.076 C 267.444,122.076 267.084,122.22 266.94,122.436 C 266.58,122.724 266.58,123.084 266.58,123.444 C 266.58,123.804 266.58,124.164 266.94,124.308 L 284.22,146.772 L 288.036,151.956 C 288.9,153.684 289.26,155.412 289.404,157.14 C 289.404,157.356 289.404,157.5 289.404,157.644 C 289.404,159.228 289.044,160.956 288.54,162.54 L 286.668,166.5 L 284.94,169.092 C 288.684,168.372 292.14,167.724 295.812,167.148 C 300.492,166.284 305.46,165.636 310.644,165.42 C 314.964,165.276 318.996,165.132 323.1,165.132 C 326.196,165.276 329.652,165.42 333.108,165.78 C 335.412,166.14 337.428,166.5 339.516,167.004 C 341.1,167.508 342.684,168.372 344.052,169.236 C 346.284,170.82 348.012,172.908 349.02,175.284 C 349.884,177.228 350.46,179.46 350.604,181.548 C 351.324,179.604 351.612,177.732 351.612,175.644 C 351.612,175.284 351.612,175.14 351.612,174.78 C 351.468,172.188 351.108,169.74 350.46,167.148 C 349.38,164.412 348.012,161.82 346.428,159.588 C 345.06,157.86 343.548,156.276 341.964,154.908 C 341.964,154.692 341.82,154.692 341.82,154.692 z "
+ id="path22" /><path
+ d="M 296.316,300.564 C 299.556,299.196 302.652,297.684 305.604,295.956 C 305.964,296.1 306.468,296.1 306.828,296.1 C 308.916,296.1 311.004,295.956 313.02,295.596 C 319.068,295.092 325.116,294.228 331.02,293.148 C 324.612,297.468 318.564,302.148 313.02,307.188 C 308.196,311.292 303.876,315.828 299.556,320.22 C 298.332,320.22 297.324,319.86 296.46,319.572 C 292.644,317.844 289.188,315.972 285.732,313.884 C 282.42,312.012 279.54,309.78 277.092,307.188 C 278.964,306.468 280.908,305.82 282.78,305.244 C 287.46,304.092 291.924,302.508 296.316,300.564 z "
+ id="path24" /></g>
+</svg> \ No newline at end of file