summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-05-03 14:11:27 -0400
committerGuillaume Horel2017-05-03 14:11:27 -0400
commita7b8f0b8d1ac90fe65a539174b527f3c7e0f6559 (patch)
treecbbb25fd5e5fba8c77467d24f50a02f51b6c7cfb
downloadaur-a7b8f0b8d1ac90fe65a539174b527f3c7e0f6559.tar.gz
initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b493cab7aef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = snappy-static
+ pkgdesc = A fast compressor/decompressor library
+ pkgver = 1.1.4
+ pkgrel = 1
+ url = https://google.github.io/snappy/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ checkdepends = zlib
+ depends = glibc
+ depends = gcc-libs
+ provides = snappy
+ conflicts = snappy
+ options = staticlibs
+ source = https://github.com/google/snappy/releases/download/1.1.4/snappy-1.1.4.tar.gz
+ md5sums = c328993b68afe3e5bd87c8ea9bdeb028
+
+pkgname = snappy-static
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebad5ca0f133
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+# Contributor: Dave Reisner <dreisner@archlinux.org>
+# Contributor: Antony Male <antony dot male at geemail dot com>>
+
+pkgname=snappy-static
+_pkgname=snappy
+pkgver=1.1.4
+pkgrel=1
+pkgdesc='A fast compressor/decompressor library'
+arch=('i686' 'x86_64')
+url="https://google.github.io/snappy/"
+license=('BSD')
+depends=('glibc' 'gcc-libs')
+provides=('snappy')
+conflicts=('snappy')
+checkdepends=('zlib')
+options=('staticlibs')
+source=("https://github.com/google/snappy/releases/download/$pkgver/$_pkgname-$pkgver.tar.gz")
+md5sums=('c328993b68afe3e5bd87c8ea9bdeb028')
+
+build() {
+ cd "$_pkgname-$pkgver"
+
+ # compile without assertions
+ CXXFLAGS+=" -DNDEBUG -fPIC"
+
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ # compile without assertions
+ CXXFLAGS+=\ -DNDEBUG
+
+ make -C "$_pkgname-$pkgver" check
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+ install -m644 -D COPYING "$pkgdir/usr/share/licenses/snappy/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: