summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu2018-08-12 02:01:32 +1000
committerJonathan Liu2018-08-12 02:01:32 +1000
commit25f54b5a6ebb2140772cce495f5861f7e1d3f600 (patch)
treefd6ba9475b09db26f13bb6ba16a390cae34c254b
parent047947eb729385ff29eac800da923993fb30f045 (diff)
downloadaur-25f54b5a6ebb2140772cce495f5861f7e1d3f600.tar.gz
Update to 4.17.14-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--lowlatency.patch14
3 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 771f714a18fc..b6b8e776d6bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = snd-usb-audio-lowlatency-dkms
pkgdesc = snd-usb-audio kernel module modified for low latency
pkgver = 4.17.14
- pkgrel = 1
+ pkgrel = 2
url = https://www.kernel.org/
arch = any
license = GPL2
@@ -15,7 +15,7 @@ pkgbase = snd-usb-audio-lowlatency-dkms
sha256sums = 9faa1dd896eaea961dc6e886697c0b3301277102e5bc976b2758f9a62d3ccd13
sha256sums = bf4d95df98dc6197024bc2a7c8a8ef5fd3b21495298c7a7a5dbd63c159ea9f17
sha256sums = 69f325c3af92c4098c9d118b2eab7de76eba691677864f714697bce5f47005e2
- sha256sums = 9da83cbdf8d8202507a45c1cd6c29b45b9e4ff483483d9957c711c0120a78fe5
+ sha256sums = 803a36109e3f0ee55c4f2f1ae32bb4cc27f78b05a4bf758ec52c1b455a5cb026
pkgname = snd-usb-audio-lowlatency-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 0f6eb38e9462..7534c273463f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=snd-usb-audio-lowlatency-dkms
_basepkgname=snd-usb-audio-lowlatency
_srcname=linux-4.17
pkgver=4.17.14
-pkgrel=1
+pkgrel=2
pkgdesc="snd-usb-audio kernel module modified for low latency"
arch=('any')
url="https://www.kernel.org/"
@@ -22,7 +22,7 @@ validpgpkeys=(
sha256sums=('9faa1dd896eaea961dc6e886697c0b3301277102e5bc976b2758f9a62d3ccd13'
'bf4d95df98dc6197024bc2a7c8a8ef5fd3b21495298c7a7a5dbd63c159ea9f17'
'69f325c3af92c4098c9d118b2eab7de76eba691677864f714697bce5f47005e2'
- '9da83cbdf8d8202507a45c1cd6c29b45b9e4ff483483d9957c711c0120a78fe5')
+ '803a36109e3f0ee55c4f2f1ae32bb4cc27f78b05a4bf758ec52c1b455a5cb026')
prepare() {
cd "${_srcname}"
diff --git a/lowlatency.patch b/lowlatency.patch
index 0fcf60f85a86..2e1d479fac14 100644
--- a/lowlatency.patch
+++ b/lowlatency.patch
@@ -1,13 +1,19 @@
--- a/sound/usb/card.h
+++ b/sound/usb/card.h
-@@ -3,8 +3,8 @@
+@@ -3,11 +3,11 @@
#define __USBAUDIO_CARD_H
#define MAX_NR_RATES 1024
-#define MAX_PACKS 6 /* per URB */
-#define MAX_PACKS_HS (MAX_PACKS * 8) /* in high speed mode */
+-#define MAX_URBS 12
+-#define SYNC_URBS 4 /* always four urbs for sync */
+-#define MAX_QUEUE 18 /* try not to exceed this queue length, in ms */
+#define MAX_PACKS 1 /* per URB */
+#define MAX_PACKS_HS (MAX_PACKS * 1) /* in high speed mode */
- #define MAX_URBS 12
- #define SYNC_URBS 4 /* always four urbs for sync */
- #define MAX_QUEUE 18 /* try not to exceed this queue length, in ms */
++#define MAX_URBS 1
++#define SYNC_URBS 1 /* always four urbs for sync */
++#define MAX_QUEUE 1 /* try not to exceed this queue length, in ms */
+
+ struct audioformat {
+ struct list_head list;