summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Schweikert2015-06-16 13:43:14 +0200
committerFlorian Schweikert2015-06-16 13:43:14 +0200
commit03700ad73cd7a8b9664c3bbbf260c89713937852 (patch)
tree01049aa531dde2580ab1a0550f8fe49b17bab2bf
downloadaur-03700ad73cd7a8b9664c3bbbf260c89713937852.tar.gz
Initial import
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
3 files changed, 57 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..a17aa8050b5d
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = sndcut
+ pkgdesc = Let's you generated LPs that you can laser cut from audio files. sndcut is a program the generates LP records from audio files - it generates a SVG file that you can laser cut.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/kallaballa/sndcut
+ arch = x86
+ arch = x86_64
+ license = GPL2
+ makedepends = boost
+ depends = libsndfile
+ depends = libsamplerate
+ depends = boost-libs
+ source = https://github.com/kallaballa/sndcut/archive/v1.0.zip
+ sha1sums = 162f8191e81e374742be6e9117f8a9c97f29bfdf
+
+pkgname = sndcut
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a17aa8050b5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = sndcut
+ pkgdesc = Let's you generated LPs that you can laser cut from audio files. sndcut is a program the generates LP records from audio files - it generates a SVG file that you can laser cut.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/kallaballa/sndcut
+ arch = x86
+ arch = x86_64
+ license = GPL2
+ makedepends = boost
+ depends = libsndfile
+ depends = libsamplerate
+ depends = boost-libs
+ source = https://github.com/kallaballa/sndcut/archive/v1.0.zip
+ sha1sums = 162f8191e81e374742be6e9117f8a9c97f29bfdf
+
+pkgname = sndcut
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e52ea02ecf99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Florian Schweikert <aur@ist-total.org>
+pkgname=sndcut
+pkgver=1.0
+pkgrel=1
+pkgdesc="Let's you generated LPs that you can laser cut from audio files.
+ sndcut is a program the generates LP records from audio files - it generates a SVG file that you can laser cut."
+arch=('x86' 'x86_64')
+url="https://github.com/kallaballa/sndcut"
+license=('GPL2')
+depends=('libsndfile' 'libsamplerate' 'boost-libs')
+makedepends=('boost')
+source=(https://github.com/kallaballa/$pkgname/archive/v$pkgver.zip)
+sha1sums=('162f8191e81e374742be6e9117f8a9c97f29bfdf')
+
+build() {
+ cd $pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+}