summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcoreymwamba2015-09-18 10:04:47 +0100
committercoreymwamba2015-09-18 10:04:47 +0100
commite79121d3746f90dd51d455cf20b72eb4841ebc19 (patch)
tree0a44cb2c398af77f38668d3d3e9ef263f153e1e9
downloadaur-e79121d3746f90dd51d455cf20b72eb4841ebc19.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--LPC.patch13
-rw-r--r--PKGBUILD38
-rw-r--r--makefile.jack.patch11
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e2537d591a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = sndpeek-jack
+ pkgdesc = a real-time audio visualization tool (animated, 3D): JACK version
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://www.gewang.com/software/sndpeek/
+ arch = i686
+ arch = x86_64
+ groups = multimedia
+ license = GPL
+ depends = libsndfile
+ depends = jack
+ depends = glu
+ depends = freeglut
+ depends = libxmu
+ provides = sndpeek
+ source = http://soundlab.cs.princeton.edu/software/sndpeek/files/sndpeek-1.4.tgz
+ source = LPC.patch
+ source = makefile.jack.patch
+ md5sums = 91df9f339230fd6c01f85ebd4cca51cb
+ md5sums = b73a667384ffa9237ded847483c796da
+ md5sums = 11e10b877c866f5d6f2b7dcee061176b
+
+pkgname = sndpeek-jack
+
diff --git a/LPC.patch b/LPC.patch
new file mode 100644
index 000000000000..fcfa7be9e229
--- /dev/null
+++ b/LPC.patch
@@ -0,0 +1,13 @@
+--- src/marsyas/LPC.cpp 2015-03-01 22:31:15.000000000 +0000
++++ src/marsyas/LPC.new.cpp 2015-09-18 09:38:40.371974107 +0100
+@@ -24,8 +24,8 @@
+ Linear Prediction Coefficients (LPC). Features commonly used
+ in Speech Recognition research.
+ */
+-
+-
++#include <cstdlib>
++#include <math.h>
+ #include "LPC.h"
+
+ LPC::LPC( unsigned int inSize )
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2a719700810
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=sndpeek-jack
+_pkgname=sndpeek
+pkgver=1.4
+pkgrel=1
+pkgdesc="a real-time audio visualization tool (animated, 3D): JACK version"
+arch=('i686' 'x86_64')
+url="http://www.gewang.com/software/sndpeek/"
+license=('GPL')
+groups=('multimedia')
+depends=('libsndfile' 'jack' 'glu' 'freeglut' 'libxmu')
+provides=('sndpeek')
+source=("http://soundlab.cs.princeton.edu/software/sndpeek/files/$_pkgname-$pkgver.tgz" "LPC.patch" "makefile.jack.patch")
+md5sums=('91df9f339230fd6c01f85ebd4cca51cb' 'b73a667384ffa9237ded847483c796da' '11e10b877c866f5d6f2b7dcee061176b')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver/src/marsyas"
+ patch -p2 -i "$srcdir/LPC.patch"
+ cd "$srcdir/$_pkgname-$pkgver/src/$_pkgname"
+ patch -i "$srcdir/makefile.jack.patch"
+}
+
+build() {
+ cd "$_pkgname-$pkgver/src/$_pkgname"
+ make linux-jack
+}
+
+package() {
+ cd "$pkgdir"
+ mkdir -p /usr/bin
+ cd "$srcdir/$_pkgname-$pkgver/src/$_pkgname"
+ install -p -D $_pkgname -m 0755 $pkgdir/usr/bin/$pkgname
+}
diff --git a/makefile.jack.patch b/makefile.jack.patch
new file mode 100644
index 000000000000..f94c30702dca
--- /dev/null
+++ b/makefile.jack.patch
@@ -0,0 +1,11 @@
+--- makefile.jack 2015-03-01 22:31:15.000000000 +0000
++++ newmake.jack 2015-09-18 08:24:08.069885577 +0100
+@@ -2,7 +2,7 @@
+ CPP=g++
+ INCLUDES=-I../marsyas/
+ MARSYAS_DIR=../marsyas/
+-CFLAGS=-D__LINUX_JACK__ -D__LITTLE_ENDIAN__ $(INCLUDES) -O3 -c
++CFLAGS=-D__LINUX_JACK__ -D__LITTLE_ENDIAN__ -D__UNIX_JACK__ $(INCLUDES) -O3 -c
+ LIBS=-L/usr/X11R6/lib -lpthread -lstdc++ -lglut -lGL -lGLU -lasound -ljack -lXmu -lX11 -lXext -lXi -lm -lsndfile
+
+ OBJS=chuck_fft.o RtAudio.o Thread.o sndpeek.o Stk.o \