summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchilleas Pipinellis2015-10-19 12:40:00 +0300
committerAchilleas Pipinellis2015-10-19 12:40:00 +0300
commit5dd0b6c5defdfb47c7420d70dbf2f53de9d59a7c (patch)
tree46551532b825d7fb5c63eae0c718d24f8a9cd6ec
parentf9a84533b707155a1ea12a420a8b0a379cac4833 (diff)
downloadaur-5dd0b6c5defdfb47c7420d70dbf2f53de9d59a7c.tar.gz
Version bump
- Bump to 0.9 - Replace python2-dialog with python2-pythondialog - Change license from BSD to GPL3
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--ChangeLog56
-rw-r--r--PKGBUILD10
4 files changed, 68 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 569388482e02..c33053e76e7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = snf-image-creator
pkgdesc = Command line tool for creating images
- pkgver = 0.8
+ pkgver = 0.9
pkgrel = 1
- url = http://docs.dev.grnet.gr/snf-image-creator/latest/
+ url = https://github.com/grnet/snf-image-creator
changelog = ChangeLog
arch = any
- license = BSD
+ license = GPL3
makedepends = python2-distribute
makedepends = python2-sphinx
depends = python2
depends = rsync
depends = libguestfs
- depends = python2-dialog
+ depends = python2-pythondialog
depends = python2-sendfile
depends = python2-progress
depends = python2-ansicolors
@@ -20,8 +20,8 @@ pkgbase = snf-image-creator
depends = python2-pyparted
optdepends = winexe: support for Windows images,
optdepends = hivex: support for Windows images
- source = https://pypi.python.org/packages/source/s/snf_image_creator/snf_image_creator-0.8.tar.gz
- md5sums = 2f7d4c2efd1b94a4fbd496ce796658b8
+ source = https://pypi.python.org/packages/source/s/snf_image_creator/snf_image_creator-0.9.tar.gz
+ md5sums = 13be21e7beebac5b81a3db5e5c0c7f38
pkgname = snf-image-creator
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1050513f3325
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*[gx]z
diff --git a/ChangeLog b/ChangeLog
index 5116a2d3f71d..164cd5ebf72f 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,59 @@
+2015-03-02, v0.9
+ * Add Linux syspreps for disabling the IPv6 privacy extensions and for
+ changing the boot timeout
+ * Add support for syslinux
+ * Add support for outputting to syslog
+ * Fix bugs
+
+2015-02-05, v0.8.1
+ * Fix a bug in the wizard that terminated the program unexpectedly
+
+2015-01-05, v0.8
+ * Support locally mounting the image on the host system
+ * Add option for running user defined scripts in the image's root after
+ locally mounting it, in the non-interactive version of the program
+ * Fully support OpenBSD and NetBSD images (libguestfs >= 1.29.4)
+ * Allow the user to save the current execution log in the dialog-based
+ version of the program
+ * Output the server answer in stdout after successfully registering an
+ image with a synnefo deployment in the non-interactive version of the
+ program
+ * Add a menu entry after "Register" to show the server's answer in the
+ dialog-based version of the program after a successful registration
+ * Automatically detect and assign SORTORDER, GUI and KERNEL metadata
+ * Fix bugs
+
+2014-11-04, v0.7.4
+ * Handle cases where qemu-nbd command is missing
+ * Create REMOTE_CONNECTION property. Can be used by cyclades to
+ determine the way to remotely connect to a VM created by this image
+
+2014-10-21, v0.7.3
+ * Instruct kamaki to ignore the ssl certificates (kamaki >= 0.13rc5).
+
+2014-10-14, v0.7.2
+ * Fix an exception triggered when collecting Ubuntu metadata
+
+2014-10-06, v0.7.1
+ * Fix a bug in host bundling operation where the file system UUIDs and
+ Labels where not preserved
+ * Fix a few bugs in the Windows deployment code
+ * Successfully detect Lubuntu and Xubuntu systems
+ * Update the documentation
+
+2014-09-26, v0.7
+ * Support all QEMU supported disk image formats as input media
+ * Detect if a Windows input media is sysprepped
+ * Support VirtIO driver installation in Windows
+ * Do a major code cleanup
+ * Fix bugs
+
+2014-06-10, v0.6.2
+ * Add support for Ubuntu 14.04
+ * Fix a bug in Windows image creation
+ * Add .kamaki.log in the user's personal data to be removed
+ * Fix minor issues in the documentation
+
2014-01-10, v0.6.1
* Comply with the AstakosClient changes made in kamaki 0.12
diff --git a/PKGBUILD b/PKGBUILD
index 2796d41c964d..4ac7d9c3e396 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_pkgname=snf_image_creator
pkgname=snf-image-creator
-pkgver=0.8
+pkgver=0.9
pkgrel=1
pkgdesc="Command line tool for creating images"
-url="http://docs.dev.grnet.gr/snf-image-creator/latest/"
+url="https://github.com/grnet/snf-image-creator"
arch=('any')
-license=('BSD')
+license=('GPL3')
changelog=ChangeLog
-depends=('python2' 'rsync' 'libguestfs' 'python2-dialog' 'python2-sendfile'
+depends=('python2' 'rsync' 'libguestfs' 'python2-pythondialog' 'python2-sendfile'
'python2-progress' 'python2-ansicolors' 'kamaki' 'python2-sh' 'python2-pyparted')
makedepends=('python2-distribute' 'python2-sphinx')
optdepends=('winexe: support for Windows images',
@@ -34,4 +34,4 @@ package() {
}
-md5sums=('2f7d4c2efd1b94a4fbd496ce796658b8')
+md5sums=('13be21e7beebac5b81a3db5e5c0c7f38')