summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchilleas Pipinellis2018-01-24 13:52:43 +0100
committerAchilleas Pipinellis2018-01-24 13:52:43 +0100
commit707d0592fd1bf9507be5e0766a785703946590ca (patch)
treec7447d959e6a484274613589dfaefc825a352615
parent55d88663791672792cf9c8678cac05e1c5757229 (diff)
downloadaur-707d0592fd1bf9507be5e0766a785703946590ca.tar.gz
Update to 0.11.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd4c45429aa6..3ffbb5e1694a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = snf-image-creator
pkgdesc = Command line tool for creating images
- pkgver = 0.9
- pkgrel = 2
+ pkgver = 0.11.1
+ pkgrel = 1
url = https://github.com/grnet/snf-image-creator
- changelog = ChangeLog
arch = any
license = GPL3
makedepends = python2-distribute
@@ -18,10 +17,10 @@ pkgbase = snf-image-creator
depends = kamaki
depends = python2-sh
depends = python2-pyparted
- optdepends = winexe: support for Windows images,
+ optdepends = winexe-git: support for Windows images,
optdepends = hivex: support for Windows images
- source = https://pypi.python.org/packages/source/s/snf_image_creator/snf_image_creator-0.9.tar.gz
- md5sums = 13be21e7beebac5b81a3db5e5c0c7f38
+ source = https://github.com/grnet/snf-image-creator/archive/0.11.1.tar.gz
+ sha256sums = 9d2f9ac93e5858a8ecf8b197da046daba483d5d4acbcf60b3d4390ce73b867a4
pkgname = snf-image-creator
diff --git a/PKGBUILD b/PKGBUILD
index 4c1ae96a3f32..5f553611243d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
-# Maintainer: Axilleas Pipinellis <axilleas@archlinux.info>
+# Maintainer: Achilleas Pipinellis <axilleas archlinux gr>
_pkgname=snf_image_creator
pkgname=snf-image-creator
-pkgver=0.9
-pkgrel=2
+pkgver=0.11.1
+pkgrel=1
pkgdesc="Command line tool for creating images"
url="https://github.com/grnet/snf-image-creator"
arch=('any')
license=('GPL3')
-changelog=ChangeLog
depends=('python2' 'rsync' 'libguestfs' 'python2-pythondialog' 'python2-sendfile'
'python2-progress' 'python2-ansicolors' 'kamaki' 'python2-sh' 'python2-pyparted')
makedepends=('python2-distribute' 'python2-sphinx')
-optdepends=('winexe: support for Windows images',
+optdepends=('winexe-git: support for Windows images',
'hivex: support for Windows images')
-source=("https://pypi.python.org/packages/source/s/$_pkgname/$_pkgname-$pkgver.tar.gz")
+source=("https://github.com/grnet/$pkgname/archive/$pkgver.tar.gz")
+
+sha256sums=('9d2f9ac93e5858a8ecf8b197da046daba483d5d4acbcf60b3d4390ce73b867a4')
package() {
cd "$srcdir/$_pkgname-$pkgver"
python2 setup.py install --root="$pkgdir" -O1
- install -Dm644 ChangeLog "$pkgdir/usr/share/$pkgname/ChangeLog"
# Build documentation and man page
cd "$srcdir/$_pkgname-$pkgver/docs"
@@ -32,5 +32,3 @@ package() {
cp -r _build/html/ "$pkgdir/usr/share/docs/$pkgname/html"
}
-
-md5sums=('13be21e7beebac5b81a3db5e5c0c7f38')