summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchilleas Pipinellis2015-06-10 09:15:45 +0300
committerAchilleas Pipinellis2015-06-10 09:15:45 +0300
commitf9a84533b707155a1ea12a420a8b0a379cac4833 (patch)
tree87c342c350449fd1af3aa17fda781d98731cf0e2
downloadaur-f9a84533b707155a1ea12a420a8b0a379cac4833.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--ChangeLog115
-rw-r--r--PKGBUILD37
3 files changed, 179 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..569388482e02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = snf-image-creator
+ pkgdesc = Command line tool for creating images
+ pkgver = 0.8
+ pkgrel = 1
+ url = http://docs.dev.grnet.gr/snf-image-creator/latest/
+ changelog = ChangeLog
+ arch = any
+ license = BSD
+ makedepends = python2-distribute
+ makedepends = python2-sphinx
+ depends = python2
+ depends = rsync
+ depends = libguestfs
+ depends = python2-dialog
+ depends = python2-sendfile
+ depends = python2-progress
+ depends = python2-ansicolors
+ depends = kamaki
+ depends = python2-sh
+ depends = python2-pyparted
+ optdepends = winexe: support for Windows images,
+ optdepends = hivex: support for Windows images
+ source = https://pypi.python.org/packages/source/s/snf_image_creator/snf_image_creator-0.8.tar.gz
+ md5sums = 2f7d4c2efd1b94a4fbd496ce796658b8
+
+pkgname = snf-image-creator
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..5116a2d3f71d
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,115 @@
+2014-01-10, v0.6.1
+ * Comply with the AstakosClient changes made in kamaki 0.12
+
+2014-01-08, v0.6
+ * Rename the dialog-based application to snf-image-creator and the
+ non-interactive command line one to snf-mkimage
+ * Support Windows Server 2012 R2
+ * Allow image creation for unsupported media
+ * Make winexe an optional dependency
+ * Fix bugs
+
+2013-10-09, v0.5.3
+ * Fix a bug in snf-mkimage expert mode were the program could crash if
+ the image did not have any image properties
+
+2013-09-09, v0.5.2
+ * Fix some errors in the ci scripts
+
+2013-08-23, v0.5.1
+ * Allow more characters in the cloud name
+ * Fix various bugs
+ * Handle kamaki config errors
+
+2013-08-04, v0.5
+ * Add support for sysprep-parameters
+ * Add support for syspreping Windows media
+ * Code cleanup
+
+2013-07-31, v0.4.4
+ * Fix a bug where the system tried to use file scrubbing without
+ checking if it was supported
+
+2013-07-18, v0.4.3
+ * Force TERM=linux when working on xterm. This makes dialog behave
+ better under OpenSUSE
+
+2013-07-17, v0.4.2
+ * Fix a dialog bug affecting only OpenSUSE
+
+2013-06-21, v0.4.1
+ * Fix a bug that caused an abnormal termination when trying to
+ determine the available users in a Windows image
+
+2013-06-21, v0.4
+ * Populate the USERS metadata in Windows images
+ * Support kamaki 0.9 and synnefo 0.14
+ * Change the metadata file format to json
+ * Support the devflow building system
+
+2013-05-27, v0.3
+ * Support media hosting FreeBSD systems
+ * Check if remote files exist when uploading images to pithos
+ * Make the md5sum and metadate files public if image gets registered as
+ public
+ * Fix minor bugs and typos
+
+2013-05-01, v0.2.10
+ * Fix a bug where acl and user_xattr mount options where not respected
+ in host bundling operation
+
+2013-04-25, v0.2.9
+ * Support kamaki 0.8
+ * Fix a bug in util.get_command()
+ * Move some linux specific code from unix.py to linux.py
+
+2013-03-28, v0.2.8
+ * Fix a bug in wizard mode
+ * Cleanup and refine the code
+
+2013-03-21, v0.2.7
+ * Fix a bug in host bundling mode where some files were erroneously
+ excluded from the image
+ * Fix a bug were snf-image-creator tried to verify the token even when
+ -t option was not defined by the user
+
+2013-03-19, v0.2.6
+ * Fix a bug in host bundling mode where the permissions of /tmp and
+ /var/tmp were not respected
+
+2013-03-19, v0.2.5
+ * Add support for private images
+ * Only use the token to authenticate to synnefo
+ * Show the user-provided info in the confirmation dialog of the wizard
+ * Fix minor typos & bugs
+
+2013-03-06, v0.2.4
+ * Rename README.rst to README
+ * Enforce raw image format in libguestfs
+ * User user id instead of e-mail when authentication with synnefo
+
+2013-01-30, v0.2.3
+ * Add support for gpt partition tables in bundle volume
+ * Add AUTHORS ChangeLog and man pages
+ * support pyparted 3.4 and python 2.6
+
+2013-01-22, v0.2.2
+ * Fix bugs in bundle_host and cleanup functions
+
+2013-01-16, v0.2.1
+ * Fix bug in dialog
+ * Support python-sendfile 2.x
+
+2013-01-14, v0.2
+ * Add support for bundling the host system
+ * Add new tmpdir option for specifying a temporary directory
+ * Add .kamakirc as sensitive userdatat in cleanup_userdata sysprep
+ * Fix typos & bugs
+
+2012-12-03, v0.1.1
+ * Fix bugs in dialog wizard
+ * Fix typos
+
+2012-11-05, v0.1
+ * Initial Version
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2796d41c964d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Axilleas Pipinellis <axilleas@archlinux.info>
+
+_pkgname=snf_image_creator
+pkgname=snf-image-creator
+pkgver=0.8
+pkgrel=1
+pkgdesc="Command line tool for creating images"
+url="http://docs.dev.grnet.gr/snf-image-creator/latest/"
+arch=('any')
+license=('BSD')
+changelog=ChangeLog
+depends=('python2' 'rsync' 'libguestfs' 'python2-dialog' 'python2-sendfile'
+'python2-progress' 'python2-ansicolors' 'kamaki' 'python2-sh' 'python2-pyparted')
+makedepends=('python2-distribute' 'python2-sphinx')
+optdepends=('winexe: support for Windows images',
+ 'hivex: support for Windows images')
+source=("https://pypi.python.org/packages/source/s/$_pkgname/$_pkgname-$pkgver.tar.gz")
+
+package() {
+
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir" -O1
+ install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 ChangeLog "$pkgdir/usr/share/$pkgname/ChangeLog"
+
+ # Build documentation and man page
+ cd "$srcdir/$_pkgname-$pkgver/docs"
+ sed -i 's/sphinx-build/sphinx-build2/' Makefile
+ make html && make man && rm -rf "_build/html/man" && rm -rf _build/doctrees
+
+ mkdir -p "$pkgdir"/usr/share/{man/man1,docs/"$pkgname"}
+ install -Dm644 _build/man/*.1 "$pkgdir/usr/share/man/man1/"
+ cp -r _build/html/ "$pkgdir/usr/share/docs/$pkgname/html"
+
+}
+
+md5sums=('2f7d4c2efd1b94a4fbd496ce796658b8')