summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBilal Elmoussaoui2017-01-14 16:05:40 +0100
committerBilal Elmoussaoui2017-01-14 16:05:40 +0100
commitce32985af0cd0e387809d855598eaf672771e335 (patch)
treedb7aef26ed57571835fcdddb61669ec188ff5a41
downloadaur-ce32985af0cd0e387809d855598eaf672771e335.tar.gz
first release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69bfd634c6e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = sni-qt-patched-git
+ pkgdesc = Qt4 plugin which turns all QSystemTrayIcon into StatusNotifierItems. Hardcode-Tray version
+ pkgver = r.
+ pkgrel = 1
+ url = https://github.com/bil-elmoussaoui/sni-qt
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = cmake
+ makedepends = git
+ depends = libdbusmenu-qt4
+ provides = sni-qt-patched
+ provides = sni-qt
+ conflicts = sni-qt-eplus
+ conflicts = sni-qt
+ backup = etc/xdg/sni-qt.conf
+ source = git://github.com/bil-elmoussaoui/sni-qt.git
+ md5sums = SKIP
+
+pkgname = sni-qt-patched-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76cf09d11d56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=sni-qt-patched-git
+_pkgname=sni-qt
+pkgver=r.
+pkgrel=1
+pkgdesc='Qt4 plugin which turns all QSystemTrayIcon into StatusNotifierItems. Hardcode-Tray version'
+arch=('i686' 'x86_64')
+url='https://github.com/bil-elmoussaoui/sni-qt'
+license=('LGPL3')
+depends=('libdbusmenu-qt4')
+makedepends=('cmake' 'git')
+backup=('etc/xdg/sni-qt.conf')
+provides=('sni-qt-patched' 'sni-qt')
+conflicts=('sni-qt-eplus' 'sni-qt')
+source=("git://github.com/bil-elmoussaoui/sni-qt.git")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir"
+ if [ -d "build" ]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd "$srcdir"/build
+ cmake ../$_pkgname \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+
+ # Install config file for apps that need "Activate" action
+ install -Dm644 "${srcdir}/${_pkgname}/debian/sni-qt.conf" "${pkgdir}/etc/xdg/sni-qt.conf"
+} \ No newline at end of file