summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeger-Jan van de Weg2019-03-02 21:14:01 +0100
committerZeger-Jan van de Weg2019-03-02 22:03:26 +0100
commitdf43861c1f46074a246353008462f87b6c743fde (patch)
treeca3f2dba242d2a7f28b330fff84a75c75a1ae48d
downloadaur-df43861c1f46074a246353008462f87b6c743fde.tar.gz
Create PKGBUILD for snippet
This repository is created to publish and maintain snippet in the AUR. the PKGBUILD will be maintained there as only repository and not have a GitLab.com mirror.
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab40f2249dad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = snippet
+ pkgdesc = A terminal based interface to create a new GitLab snippet
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://gitlab.com/zj/snippet
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ provides = snippet
+ conflicts = snippet
+ source = snippet-0.3.0.tar.gz::https://gitlab.com/zj/snippet/-/archive/0.3.0/snippet-0.3.0.tar.gz
+ sha256sums = e518ba75089a706b57149c99475fbccab51c2fc906c6cc0e6124e370087ab61e
+
+pkgname = snippet
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..57aa81f55b6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+*.tar.gz
+src/
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60485fdb5b31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Zeger-Jan van de Weg <git@zjvandeweg.nl> -> https://gitlab.com/zj
+
+pkgname=snippet
+pkgver=0.3.0
+pkgrel=1
+pkgdesc='A terminal based interface to create a new GitLab snippet'
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
+url="https://gitlab.com/zj/snippet"
+license=(MIT)
+provides=(snippet)
+conflicts=(snippet)
+makedepends=("go" "git")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('e518ba75089a706b57149c99475fbccab51c2fc906c6cc0e6124e370087ab61e')
+
+build() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ GO111MODULE=on go build -mod=vendor
+}
+
+package() {
+ install -Dm755 "${srcdir}"/${pkgname}-${pkgver}/snippet "${pkgdir}"/usr/bin/snippet
+}