summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2012-05-02 13:59:57 +0200
committerCedric Girard2012-05-02 13:59:57 +0200
commit87aecb805bfff9a891deb77df3b1c834deb630e8 (patch)
tree8b85aba28fdbde40fe849d64b592286c7d5f9a88
downloadaur-87aecb805bfff9a891deb77df3b1c834deb630e8.tar.gz
new pkgbuild: snmp simulator
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b9f3b6675f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = snmpsim
+ pkgdesc = a software that would act like a multitude of real physical devices from SNMP Manager's point of view
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = http://snmpsim.sourceforge.net/
+ arch = any
+ license = BSD
+ depends = python
+ depends = python-pysnmp
+ depends = python-pyasn1
+ optdepends = pycrypto: SNMPv3 support
+ options = !emptydirs
+ source = http://downloads.sourceforge.net/project/snmpsim/snmpsim/0.1.3/snmpsim-0.1.3.tar.gz
+ md5sums = 93719ca49ed013c3819a1f057a412347
+
+pkgname = snmpsim
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e293b51171f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+pkgname=snmpsim
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="a software that would act like a multitude of real physical devices from SNMP Manager's point of view"
+arch=(any)
+url="http://snmpsim.sourceforge.net/"
+license=('BSD')
+depends=('python' 'python-pysnmp' 'python-pyasn1')
+optdepends=('pycrypto: SNMPv3 support')
+options=(!emptydirs)
+source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz)
+md5sums=('93719ca49ed013c3819a1f057a412347')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i '1i #!/usr/bin/env python' build/scripts-3.2/*.py
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: