summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-12-15 10:00:18 -0800
committerAndy Weidenbaum2015-12-15 10:00:18 -0800
commit2a8c4312625d932d0966b093bb739f6480e806c9 (patch)
tree4296e6107627e4212acc64f61b31829ef6dbe848
downloadaur-2a8c4312625d932d0966b093bb739f6480e806c9.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8991f526ddf2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Dec 15 18:00:08 UTC 2015
+pkgbase = snooze-git
+ pkgdesc = Run a command at a particular time
+ pkgver = 20151106
+ pkgrel = 1
+ url = https://github.com/chneukirchen/snooze
+ arch = i686
+ arch = x86_64
+ license = CC0
+ makedepends = git
+ makedepends = make
+ provides = snooze
+ conflicts = snooze
+ source = git+https://github.com/chneukirchen/snooze
+ sha256sums = SKIP
+
+pkgname = snooze-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d13e43a9f536
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=snooze-git
+pkgver=20151106
+pkgrel=1
+pkgdesc="Run a command at a particular time"
+arch=('i686' 'x86_64')
+makedepends=('git' 'make')
+url="https://github.com/chneukirchen/snooze"
+license=('CC0')
+source=(git+https://github.com/chneukirchen/snooze)
+sha256sums=('SKIP')
+provides=('snooze')
+conflicts=('snooze')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+build() {
+ cd ${pkgname%-git}
+
+ msg2 'Building...'
+ make
+}
+
+package() {
+ cd ${pkgname%-git}
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/snooze"
+
+ msg2 'Installing...'
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+}