summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2015-04-26 18:06:06 +0200
committerJaroslav Lichtblau2015-04-26 18:06:06 +0200
commit4de2d6fe20f72e78324851b961f7bb4b0efeddd3 (patch)
tree1d4d1f826de673c0feb531edf0115b62e5947baa
downloadaur-4de2d6fe20f72e78324851b961f7bb4b0efeddd3.tar.gz
new package created: snorenotify-0.5.2-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..145a4c863abe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = snorenotify
+ pkgdesc = Multi-platform Qt5 notification framework
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://github.com/Snorenotify/Snorenotify
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = cmake
+ makedepends = doxygen
+ makedepends = extra-cmake-modules
+ depends = qt5-base
+ depends = qt5-quick1
+ source = snorenotify-0.5.2.tar.gz::https://github.com/Snorenotify/Snorenotify/archive/v0.5.2.tar.gz
+ md5sums = 508dafd77c2cb1b57239c1dc6ad73727
+
+pkgname = snorenotify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5dd8f0f90c42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archinux.org>
+
+pkgname=snorenotify
+pkgver=0.5.2
+pkgrel=1
+pkgdesc='Multi-platform Qt5 notification framework'
+arch=('i686' 'x86_64')
+url='https://github.com/Snorenotify/Snorenotify'
+license=('LGPL3')
+depends=('qt5-base' 'qt5-quick1')
+makedepends=('cmake' 'doxygen' 'extra-cmake-modules')
+source=($pkgname-$pkgver.tar.gz::https://github.com/Snorenotify/Snorenotify/archive/v$pkgver.tar.gz)
+md5sums=('508dafd77c2cb1b57239c1dc6ad73727')
+
+build() {
+ cd "${srcdir}"/Snorenotify-$pkgver
+
+ cmake -DWITH_QT4=OFF -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ cd "${srcdir}"/Snorenotify-$pkgver
+
+ make DESTDIR="${pkgdir}" install
+}