summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2015-12-05 22:08:20 +0100
committerJaroslav Lichtblau2015-12-05 22:08:20 +0100
commitb86c420ce4a4f9b4815d23fd81c3521f55a01bc6 (patch)
tree5cba415627c6fc96fbcc6cab7bb585ecb1f8d12a
parent4de2d6fe20f72e78324851b961f7bb4b0efeddd3 (diff)
downloadaur-b86c420ce4a4f9b4815d23fd81c3521f55a01bc6.tar.gz
snorenotify-0.6.0-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--snorenotify.install11
3 files changed, 27 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 145a4c863abe..dbc52b4b7f07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,11 @@
+# Generated by mksrcinfo v8
+# Sat Dec 5 21:07:35 UTC 2015
pkgbase = snorenotify
pkgdesc = Multi-platform Qt5 notification framework
- pkgver = 0.5.2
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/Snorenotify/Snorenotify
+ install = snorenotify.install
arch = i686
arch = x86_64
license = LGPL3
@@ -11,8 +14,9 @@ pkgbase = snorenotify
makedepends = extra-cmake-modules
depends = qt5-base
depends = qt5-quick1
- source = snorenotify-0.5.2.tar.gz::https://github.com/Snorenotify/Snorenotify/archive/v0.5.2.tar.gz
- md5sums = 508dafd77c2cb1b57239c1dc6ad73727
+ depends = hicolor-icon-theme
+ source = snorenotify-0.6.0.tar.gz::https://github.com/Snorenotify/Snorenotify/archive/v0.6.0.tar.gz
+ md5sums = fc2074ffd9d639e966ff8c01543ece8e
pkgname = snorenotify
diff --git a/PKGBUILD b/PKGBUILD
index 5dd8f0f90c42..7cd4ab54308f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,30 @@
# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archinux.org>
pkgname=snorenotify
-pkgver=0.5.2
+pkgver=0.6.0
pkgrel=1
pkgdesc='Multi-platform Qt5 notification framework'
arch=('i686' 'x86_64')
url='https://github.com/Snorenotify/Snorenotify'
license=('LGPL3')
-depends=('qt5-base' 'qt5-quick1')
+depends=('qt5-base' 'qt5-quick1' 'hicolor-icon-theme')
makedepends=('cmake' 'doxygen' 'extra-cmake-modules')
+install=$pkgname.install
source=($pkgname-$pkgver.tar.gz::https://github.com/Snorenotify/Snorenotify/archive/v$pkgver.tar.gz)
-md5sums=('508dafd77c2cb1b57239c1dc6ad73727')
+md5sums=('fc2074ffd9d639e966ff8c01543ece8e')
build() {
- cd "${srcdir}"/Snorenotify-$pkgver
+ cd "${srcdir}"/$pkgname-$pkgver
cmake -DWITH_QT4=OFF -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib
make
}
package() {
- cd "${srcdir}"/Snorenotify-$pkgver
+ cd "${srcdir}"/$pkgname-$pkgver
make DESTDIR="${pkgdir}" install
+
+ install -d "${pkgdir}"/usr/lib/qt
+ mv "${pkgdir}"/usr/mkspecs "${pkgdir}"/usr/lib/qt
}
diff --git a/snorenotify.install b/snorenotify.install
new file mode 100644
index 000000000000..e70c054ec6ad
--- /dev/null
+++ b/snorenotify.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}