summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonny Lorenz2015-09-19 14:37:36 +0200
committerRonny Lorenz2015-09-19 14:37:36 +0200
commit25fc387c113d9d7d4f105526629fe43d4dda3e1b (patch)
treef3d71fb8ac9dd27f57d717bbe4b649a51e232598
parent2a5c21d596c12fdaf26b667718017fcd0733f48e (diff)
downloadaur-25fc387c113d9d7d4f105526629fe43d4dda3e1b.tar.gz
Fixed some autotools warnings
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--buildfix.patch44
3 files changed, 34 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69353c5d99e5..697c810f22e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,11 +5,12 @@ pkgbase = snoreport
arch = x86_64
arch = i686
license = Custom
+ makedepends = autoconf
depends = viennarna
source = http://www.bioinf.uni-leipzig.de/Software/snoReport/SnoReport-1.3.tar.gz
source = buildfix.patch
- md5sums = SKIP
- md5sums = SKIP
+ md5sums = 299d6cd2344ff376eeb8541daeacced0
+ md5sums = 592a51a1c0261b4df627635831056513
pkgname = snoreport
diff --git a/PKGBUILD b/PKGBUILD
index 3b140aae2c49..f1ff3e9509eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,12 @@ license=('Custom')
url="http://www.bioinf.uni-leipzig.de/Software/snoReport/"
depends=('viennarna')
optdepends=()
-makedepends=()
+makedepends=('autoconf')
provides=()
source=(http://www.bioinf.uni-leipzig.de/Software/snoReport/SnoReport-${pkgver}.tar.gz
buildfix.patch)
-md5sums=( 'SKIP'
- 'SKIP')
+md5sums=( '299d6cd2344ff376eeb8541daeacced0'
+ '592a51a1c0261b4df627635831056513')
prepare() {
cd "${srcdir}/SnoReport-${pkgver}"
diff --git a/buildfix.patch b/buildfix.patch
index 7ed24d7c3646..bd8bff63e165 100644
--- a/buildfix.patch
+++ b/buildfix.patch
@@ -1,6 +1,32 @@
+diff -urN SnoReport-1.3/Makefile.am SnoReport-1.3a/Makefile.am
+--- SnoReport-1.3/Makefile.am 2014-12-04 11:40:34.000000000 +0100
++++ SnoReport-1.3a/Makefile.am 2015-09-19 14:24:17.017484372 +0200
+@@ -10,6 +10,10 @@
+
+ EXTRA_DIST = $(pkgdata_DATA) $(man_MANS)
+
++LDADD = $(RNALIB_LIBS)
++
++AM_CPPFLAGS = $(RNALIB_CFLAGS)
++
+ # install the man pages
+ man_MANS = snoReport.1
+
+diff -urN SnoReport-1.3/configure.in SnoReport-1.3a/configure.in
--- SnoReport-1.3/configure.in 2014-12-04 11:51:17.000000000 +0100
-+++ SnoReport-1.3a/configure.in 2015-09-19 14:12:20.588476347 +0200
-@@ -14,29 +14,24 @@
++++ SnoReport-1.3a/configure.in 2015-09-19 14:33:10.517596799 +0200
+@@ -2,7 +2,9 @@
+
+ AC_INIT([snoReport], [1.3], [jana@bioinf.uni-leipzig.de], [snoReport])
+ dnl Every other copy of the package version number gets its value from here
+-AM_INIT_AUTOMAKE(snoReport,1.3)
++
++AM_SILENT_RULES([yes])
++AM_INIT_AUTOMAKE([1.11])
+
+ dnl create a config.h file (Automake will add -DHAVE_CONFIG_H)
+ AM_CONFIG_HEADER(config.h)
+@@ -14,29 +16,24 @@
AC_CANONICAL_HOST
@@ -41,17 +67,3 @@
dnl Checks for header files.
AC_HEADER_STDC
-diff -urN SnoReport-1.3/Makefile.am SnoReport-1.3a/Makefile.am
---- SnoReport-1.3/Makefile.am 2014-12-04 11:40:34.000000000 +0100
-+++ SnoReport-1.3a/Makefile.am 2015-09-19 14:24:17.017484372 +0200
-@@ -10,6 +10,10 @@
-
- EXTRA_DIST = $(pkgdata_DATA) $(man_MANS)
-
-+LDADD = $(RNALIB_LIBS)
-+
-+AM_CPPFLAGS = $(RNALIB_CFLAGS)
-+
- # install the man pages
- man_MANS = snoReport.1
-