summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302020-08-24 20:51:21 +0200
committerM0Rf302020-08-24 20:51:21 +0200
commitc016617dd5468c98cdf3718dd78fd5888bf0ff2b (patch)
tree05eb557ca313dd748b65cfba76d38f0b1418e55b
parente7937ea6ad846155af2d9799e478c7cd9736f098 (diff)
downloadaur-c016617dd5468c98cdf3718dd78fd5888bf0ff2b.tar.gz
snort: 2.9.16.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--snort-2.9.15.1-fno-common.patch106
3 files changed, 9 insertions, 124 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64aeb576a3c7..431e8be97c52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = snort
pkgdesc = A lightweight network intrusion detection system.
- pkgver = 2.9.16
- pkgrel = 2
+ pkgver = 2.9.16.1
+ pkgrel = 1
url = http://www.snort.org
install = snort.install
arch = i686
@@ -33,14 +33,12 @@ pkgbase = snort
backup = etc/snort/reference.config
backup = etc/snort/classification.config
backup = etc/snort/rules/emerging.conf
- source = https://www.snort.org/downloads/snort/snort-2.9.16.tar.gz
+ source = https://www.snort.org/downloads/snort/snort-2.9.16.1.tar.gz
source = http://rules.emergingthreats.net/open/snort-2.9.0/emerging.rules.tar.gz
source = snort@.service
- source = snort-2.9.15.1-fno-common.patch
- md5sums = 1cec58babaea3420014d61a93e6e1545
+ md5sums = ec148a494cde9095fb590a51efa306de
md5sums = SKIP
md5sums = a847030a34396e6b2d1cacd272ad42da
- md5sums = 101bc0617d1547b14359ad884ac70541
pkgname = snort
diff --git a/PKGBUILD b/PKGBUILD
index 0c98893624a7..53820a1ddef1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
# Contributor: Netboy3
pkgname=snort
-pkgver=2.9.16
-pkgrel=2
+pkgver=2.9.16.1
+pkgrel=1
pkgdesc='A lightweight network intrusion detection system.'
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64' 'arm')
url='http://www.snort.org'
@@ -25,14 +25,8 @@ install='snort.install'
source=("https://www.snort.org/downloads/snort/${pkgname}-${pkgver}.tar.gz"
"http://rules.emergingthreats.net/open/${pkgname}-2.9.0/emerging.rules.tar.gz"
'snort@.service'
- 'snort-2.9.15.1-fno-common.patch'
)
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i ../snort-2.9.15.1-fno-common.patch
-}
-
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr \
@@ -66,7 +60,6 @@ package() {
cp ${srcdir}/rules/* "${pkgdir}/etc/snort/rules"
}
-md5sums=('1cec58babaea3420014d61a93e6e1545'
- 'SKIP'
- 'a847030a34396e6b2d1cacd272ad42da'
-'101bc0617d1547b14359ad884ac70541')
+md5sums=('ec148a494cde9095fb590a51efa306de'
+ 'SKIP'
+ 'a847030a34396e6b2d1cacd272ad42da')
diff --git a/snort-2.9.15.1-fno-common.patch b/snort-2.9.15.1-fno-common.patch
deleted file mode 100644
index 9fe39933ddfe..000000000000
--- a/snort-2.9.15.1-fno-common.patch
+++ /dev/null
@@ -1,106 +0,0 @@
---- a/src/preprocessors/Stream6/stream_paf.h
-+++ b/src/preprocessors/Stream6/stream_paf.h
-@@ -68,12 +68,14 @@
- uint16_t s5_paf_port_registration_all (void* pv, uint16_t port, bool c2s, bool flush);
- uint16_t s5_paf_service_registration (void* pv, uint16_t service, bool c2s, bool flush);
-
--enum FlushMode
-+typedef enum
- {
- FLUSH_MODE_NORMAL = 0,
- FLUSH_MODE_PRE_DISCARD,
- FLUSH_MODE_DISCARD
--}FlushMode;
-+} FlushMode_t;
-+
-+extern FlushMode_t FlushMode;
-
- typedef struct {
- void* user[MAX_PAF_USER]; // arbitrary user data
---- a/src/sfutil/util_jsnorm.h
-+++ b/src/sfutil/util_jsnorm.h
-@@ -42,5 +42,7 @@
- uint16_t alerts;
- }JSState;
-
-+extern int hex_lookup[256];
-+
- int JSNormalizeDecode(char *, uint16_t , char *, uint16_t destlen, char **, int *, JSState *, uint8_t *);
- void InitJSNormLookupTable(void);
---- a/src/preprocessors/spp_session.h
-+++ b/src/preprocessors/spp_session.h
-@@ -28,6 +28,8 @@
- #include "decode.h"
- #include "session_common.h"
-
-+extern PreprocStats sessionPerfStats;
-+
- /* list of function prototypes for this preprocessor */
- void SetupSessionManager(void);
- void SessionReload(struct _SessionCache* lws_cache, uint32_t max_sessions,
---- a/src/preprocessors/spp_httpinspect.c
-+++ b/src/preprocessors/spp_httpinspect.c
-@@ -161,7 +161,6 @@
- MemPool *http_mempool = NULL;
- MemPool *mime_decode_mempool = NULL;
- MemPool *mime_log_mempool = NULL;
--int hex_lookup[256];
- int valid_lookup[256];
-
- char** xffFields = NULL;
---- a/src/detection-plugins/sp_session.c
-+++ b/src/detection-plugins/sp_session.c
-@@ -80,7 +80,7 @@
- #include "snort.h"
- #include "profiler.h"
- #ifdef PERF_PROFILING
--PreprocStats sessionPerfStats;
-+PreprocStats sp_sessionPerfStats;
- extern PreprocStats ruleOTNEvalPerfStats;
- #endif
-
-@@ -149,7 +149,7 @@
- /* map the keyword to an initialization/processing function */
- RegisterRuleOption("session", SessionInit, NULL, OPT_TYPE_LOGGING, NULL);
- #ifdef PERF_PROFILING
-- RegisterPreprocessorProfile("session", &sessionPerfStats, 3, &ruleOTNEvalPerfStats, NULL);
-+ RegisterPreprocessorProfile("session", &sp_sessionPerfStats, 3, &ruleOTNEvalPerfStats, NULL);
- #endif
- DEBUG_WRAP(DebugMessage(DEBUG_PLUGIN, "Plugin: Session Setup\n"););
- }
-@@ -287,7 +287,7 @@
- FILE *session; /* session file ptr */
- PROFILE_VARS;
-
-- PREPROC_PROFILE_START(sessionPerfStats);
-+ PREPROC_PROFILE_START(sp_sessionPerfStats);
-
- /* if there's data in this packet */
- if(p != NULL)
-@@ -298,7 +298,7 @@
-
- if(session == NULL)
- {
-- PREPROC_PROFILE_END(sessionPerfStats);
-+ PREPROC_PROFILE_END(sp_sessionPerfStats);
- return DETECTION_OPTION_MATCH;
- }
-
-@@ -308,7 +308,7 @@
- }
- }
-
-- PREPROC_PROFILE_END(sessionPerfStats);
-+ PREPROC_PROFILE_END(sp_sessionPerfStats);
- return DETECTION_OPTION_MATCH;
- }
-
---- a/src/detection-plugins/sp_session.h
-+++ b/src/detection-plugins/sp_session.h
-@@ -29,5 +29,6 @@
- void SetupSession(void);
- uint32_t SessionHash(void *d);
- int SessionCompare(void *l, void *r);
-+extern PreprocStats sp_sessionPerfStats;
-
- #endif /* __SP_SESSION_H__ */