summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmish2019-10-20 11:09:01 +0530
committerAmish2019-10-20 11:09:01 +0530
commitfe284c41ddacdf5a72c8d92acf8e9a0fa5a3d93e (patch)
treecce0690322d425436a2277fe9f97ccf27de42068
parentc9617c2fa2984e002012266b5638f047c21d0c55 (diff)
downloadaur-fe284c41ddacdf5a72c8d92acf8e9a0fa5a3d93e.tar.gz
Update to 2.9.15 with patch for gettid()
-rw-r--r--.SRCINFO10
-rw-r--r--001-gettid.patch17
-rw-r--r--PKGBUILD13
3 files changed, 33 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8953ddad237..f73f669f446e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = snort-nfqueue
pkgdesc = A lightweight network IDS / IPS with NFQUEUE and OpenAppID support.
- pkgver = 2.9.14.1
- pkgrel = 2
+ pkgver = 2.9.15
+ pkgrel = 1
url = https://www.snort.org
install = snort.install
arch = i686
@@ -37,14 +37,16 @@ pkgbase = snort-nfqueue
backup = etc/snort/reference.config
backup = etc/snort/classification.config
backup = etc/logrotate.d/snort
- source = https://www.snort.org/downloads/snort/snort-2.9.14.1.tar.gz
+ source = https://www.snort.org/downloads/snort/snort-2.9.15.tar.gz
source = snort-openappid.tar.gz::https://snort.org/downloads/openappid/11581
+ source = 001-gettid.patch
source = snort.logrotate
source = snort.sysusers
source = snort.tmpfiles
source = snort.service
- sha256sums = 2472989da3aace000d1ea5931ece68f8e5cc0c511e272d65182113a2481e822d
+ sha256sums = bfb437746446ef72a03c501db13cd6da5edd2b41f55c80c437ba288be6da7dba
sha256sums = 7582fc56d1412881d21eafaa081cc93a586ca7f68e8e00e62c77da37de8c5424
+ sha256sums = a1e451b8e580645a60314781c75ba57502e9a1539b28f29b10a46ddc411dceba
sha256sums = 7fe712141f651254b8e5aa0b3b7d73622d2d1d89bf53d7a522f8c1a067938421
sha256sums = ae3245c5de527fb487c459f2f4a9c78803ae6341e9c81b9a404277679cdee051
sha256sums = a92c591c409fc06661865988795093b0fb0447f614ac77951dbf9b1f6a8cf139
diff --git a/001-gettid.patch b/001-gettid.patch
new file mode 100644
index 000000000000..00873b919e60
--- /dev/null
+++ b/001-gettid.patch
@@ -0,0 +1,17 @@
+--- a/src/util.h
++++ b/src/util.h
+@@ -374,6 +374,7 @@ static inline int IsEmptyStr(const char *str)
+ return 0;
+ }
+
++#if !defined(__GLIBC__) || !defined(__GLIBC_PREREQ) || !__GLIBC_PREREQ(2, 30)
+ static inline pid_t gettid(void)
+ {
+ #if defined(LINUX) && defined(SYS_gettid)
+@@ -382,5 +383,6 @@ static inline pid_t gettid(void)
+ return getpid();
+ #endif
+ }
++#endif
+
+ #endif /*__UTIL_H__*/
diff --git a/PKGBUILD b/PKGBUILD
index bf334b280252..78d6d1681242 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
pkgname=snort-nfqueue
_pkgname=snort
-pkgver=2.9.14.1
-pkgrel=2
+pkgver=2.9.15
+pkgrel=1
pkgdesc='A lightweight network IDS / IPS with NFQUEUE and OpenAppID support.'
arch=('i686' 'x86_64')
url='https://www.snort.org'
@@ -30,17 +30,24 @@ options=('!makeflags' '!libtool')
install=snort.install
source=("https://www.snort.org/downloads/snort/${_pkgname}-${pkgver}.tar.gz"
'snort-openappid.tar.gz::https://snort.org/downloads/openappid/11581'
+ '001-gettid.patch'
'snort.logrotate'
'snort.sysusers'
'snort.tmpfiles'
'snort.service')
-sha256sums=('2472989da3aace000d1ea5931ece68f8e5cc0c511e272d65182113a2481e822d'
+sha256sums=('bfb437746446ef72a03c501db13cd6da5edd2b41f55c80c437ba288be6da7dba'
'7582fc56d1412881d21eafaa081cc93a586ca7f68e8e00e62c77da37de8c5424'
+ 'a1e451b8e580645a60314781c75ba57502e9a1539b28f29b10a46ddc411dceba'
'7fe712141f651254b8e5aa0b3b7d73622d2d1d89bf53d7a522f8c1a067938421'
'ae3245c5de527fb487c459f2f4a9c78803ae6341e9c81b9a404277679cdee051'
'a92c591c409fc06661865988795093b0fb0447f614ac77951dbf9b1f6a8cf139'
'b904ed172ea0c1a4eeaddb30745aadb8db21e333eb9faaf93400ce3db166f90d')
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch -p1 -i ../001-gettid.patch
+}
+
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
./configure --prefix=/usr --sysconfdir=/etc/snort --with-libpcap-includes=/usr/include/pcap \