summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2021-12-11 00:24:00 -0500
committerTony Lambiris2021-12-11 00:24:00 -0500
commite5652e4d5142c09c54a532ef330b032bed4f9fe3 (patch)
treea5e67fba36c3d6961ffc389b278e0ad7d9af9271
parentf05f41d32016e13db2e95a5d7720f2fcc46e105b (diff)
downloadaur-e5652e4d5142c09c54a532ef330b032bed4f9fe3.tar.gz
Version bump
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD73
-rw-r--r--dynamiclib.patch30
4 files changed, 60 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 019f04b9fb69..59c7da1a64f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = snowball-git
pkgdesc = String processing language for creating stemming algorithms
- pkgver = r662.d29510a
+ pkgver = v2.2.0.r1.gfda00a2
pkgrel = 1
url = http://snowballstem.org/
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = snowball-git
source = snowball-git::git+https://github.com/snowballstem/snowball
source = dynamiclib.patch
sha256sums = SKIP
- sha256sums = 99511a11cdeeb1ef1eaa9d7b777f6934693d4696ba9523de40b886f7d898058e
+ sha256sums = 97d21ddfd47ab4fc26cfb8b8fe9a93a3828236cd899d751b130818ca5b35580f
pkgname = snowball-git
provides = snowball
@@ -20,4 +20,3 @@ pkgname = libstemmer-git
pkgdesc = Stemming library supporting several languages
provides = libstemmer
conflicts = libstemmer
-
diff --git a/.gitignore b/.gitignore
index 3b9750fadc51..c0f9b867ec63 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
src
pkg
snowball-git
-*pkg.tar.xz
+*.pkg.tar.*
+tags
diff --git a/PKGBUILD b/PKGBUILD
index d3fe1664df4a..22eb735c8b2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Tony Lambiris <tony@criticalstack.com>
+# Maintainer: Tony Lambiris <tony@libpcap.net>
pkgbase=snowball-git
pkgname=(snowball-git libstemmer-git)
-pkgver=r662.d29510a
+pkgver=v2.2.0.r1.gfda00a2
pkgrel=1
pkgdesc="String processing language for creating stemming algorithms"
arch=(x86_64)
@@ -10,53 +10,60 @@ url="http://snowballstem.org/"
license=(BSD)
depends=(glibc)
makedepends=(git)
-source=("$pkgbase::git+https://github.com/snowballstem/snowball"
- dynamiclib.patch)
+source=("${pkgbase}::git+https://github.com/snowballstem/snowball"
+ "dynamiclib.patch")
sha256sums=('SKIP'
- '99511a11cdeeb1ef1eaa9d7b777f6934693d4696ba9523de40b886f7d898058e')
+ '97d21ddfd47ab4fc26cfb8b8fe9a93a3828236cd899d751b130818ca5b35580f')
prepare() {
- cd $pkgbase
- patch -Np1 -i ../dynamiclib.patch
+ cd "${pkgbase}"
+
+ patch -Np1 -i ../dynamiclib.patch
}
pkgver() {
- cd $pkgbase
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${pkgbase}"
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd $pkgbase
- make
+ cd "${pkgbase}"
+
+ make CFLAGS="-fPIC"
}
check() {
- cd $pkgbase
- # Disabled - needs external test data
- #make check
+ cd "${pkgbase}"
+
+ # Disabled - needs external test data
+ #make check
}
package_snowball-git() {
- pkgname=(snowball-git)
- conflicts=(snowball)
- provides=(snowball)
-
- cd $pkgbase
- install -d "$pkgdir/usr/bin"
- install -t "$pkgdir/usr/bin" snowball stemwords
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/snowball/LICENSE"
+ pkgname=(snowball-git)
+ conflicts=(snowball)
+ provides=(snowball)
+
+ cd "${pkgbase}"
+
+ install -d "${pkgdir}/usr/bin"
+ install -t "${pkgdir}/usr/bin" snowball stemwords
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/snowball-git/LICENSE"
}
package_libstemmer-git() {
- pkgname=(libstemmer-git)
- conflicts=(libstemmer)
- provides=(libstemmer)
-
- pkgdesc="Stemming library supporting several languages"
- cd $pkgbase
- install -Dm644 {.,"$pkgdir"/usr}/include/libstemmer.h
- install -D {.,"$pkgdir"/usr/lib}/libstemmer.so.0.0.0
- ln -s libstemmer.so.0.0.0 "$pkgdir/usr/lib/libstemmer.so.0"
- ln -s libstemmer.so.0 "$pkgdir/usr/lib/libstemmer.so"
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/libstemmer/LICENSE"
+ pkgname=(libstemmer-git)
+ conflicts=(libstemmer)
+ provides=(libstemmer)
+
+ pkgdesc="Stemming library supporting several languages"
+
+ cd "${pkgbase}"
+
+ install -Dm644 {.,"${pkgdir}"/usr}/include/libstemmer.h
+ install -D {.,"${pkgdir}"/usr/lib}/libstemmer.so.0.0.0
+ ln -s libstemmer.so.0.0.0 "${pkgdir}/usr/lib/libstemmer.so.0"
+ ln -s libstemmer.so.0 "${pkgdir}/usr/lib/libstemmer.so"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/libstemmer-git/LICENSE"
}
diff --git a/dynamiclib.patch b/dynamiclib.patch
index 7d86cde1ba63..408afaf6e0e5 100644
--- a/dynamiclib.patch
+++ b/dynamiclib.patch
@@ -1,29 +1,31 @@
-diff --git c/GNUmakefile i/GNUmakefile
-index 1693f5a..b33a42e 100644
---- c/GNUmakefile
-+++ i/GNUmakefile
-@@ -112,10 +112,10 @@ C_OTHER_OBJECTS = $(C_OTHER_SOURCES:.c=.o)
+diff --git a/GNUmakefile b/GNUmakefile
+index 98eb1fa..b9551b1 100644
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -170,12 +170,12 @@ C_OTHER_OBJECTS = $(C_OTHER_SOURCES:.c=.o)
JAVA_CLASSES = $(JAVA_SOURCES:.java=.class)
JAVA_RUNTIME_CLASSES=$(JAVARUNTIME_SOURCES:.java=.class)
-CFLAGS=-O2 -W -Wall -Wmissing-prototypes -Wmissing-declarations
+CFLAGS=-O2 -fPIC -W -Wall -Wmissing-prototypes -Wmissing-declarations
- CPPFLAGS=-Iinclude
+ CPPFLAGS=
--all: snowball libstemmer.o stemwords $(C_OTHER_SOURCES) $(C_OTHER_HEADERS) $(C_OTHER_OBJECTS)
-+all: snowball libstemmer.o libstemmer.so stemwords $(C_OTHER_SOURCES) $(C_OTHER_HEADERS) $(C_OTHER_OBJECTS)
+ INCLUDES=-Iinclude
- clean:
- rm -f $(COMPILER_OBJECTS) $(RUNTIME_OBJECTS) \
-@@ -158,6 +158,9 @@ libstemmer/libstemmer.o: libstemmer/modules.h $(C_LIB_HEADERS)
- libstemmer.o: libstemmer/libstemmer.o $(RUNTIME_OBJECTS) $(C_LIB_OBJECTS)
+-all: snowball$(EXEEXT) libstemmer.a stemwords$(EXEEXT) $(C_OTHER_SOURCES) $(C_OTHER_HEADERS) $(C_OTHER_OBJECTS)
++all: snowball libstemmer.a libstemmer.so stemwords $(C_OTHER_SOURCES) $(C_OTHER_HEADERS) $(C_OTHER_OBJECTS)
+
+ algorithms.mk: libstemmer/mkalgorithms.pl libstemmer/modules.txt
+ libstemmer/mkalgorithms.pl algorithms.mk libstemmer/modules.txt
+@@ -225,6 +225,9 @@ libstemmer/libstemmer.o: libstemmer/modules.h $(C_LIB_HEADERS)
+ libstemmer.a: libstemmer/libstemmer.o $(RUNTIME_OBJECTS) $(C_LIB_OBJECTS)
$(AR) -cru $@ $^
+libstemmer.so: libstemmer/libstemmer.o $(RUNTIME_OBJECTS) $(C_LIB_OBJECTS)
+ $(CC) $(CFLAGS) -shared $(LDFLAGS) -Wl,-soname,libstemmer.so.0,-version-script,libstemmer/symbol.map -o $@.0.0.0 $^
+
- stemwords: $(STEMWORDS_OBJECTS) libstemmer.o
- $(CC) -o $@ $^
+ examples/%.o: examples/%.c
+ $(CC) $(CFLAGS) $(INCLUDES) $(CPPFLAGS) -c -o $@ $<
diff --git c/libstemmer/symbol.map i/libstemmer/symbol.map
new file mode 100644