summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLance Chen2015-01-31 02:22:42 +0800
committerLance Chen2015-10-13 12:31:47 +0800
commitfa246fb6274b228e76b40b5c20c2e689cb40e221 (patch)
treed1f1197297f6951851ed2641e52d2c3150d6d937
downloadaur-fa246fb6274b228e76b40b5c20c2e689cb40e221.tar.gz
Add PKGBUILD
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD42
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fdad95cce20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = snowcrash
+ pkgdesc = API Blueprint Parser
+ pkgver = 0.16.1.r28.gd4b6e17
+ pkgrel = 1
+ url = https://github.com/apiaryio/snowcrash
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ source = git+https://github.com/apiaryio/snowcrash
+ md5sums = SKIP
+
+pkgname = snowcrash
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a290b4cca8e6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.tar
+*.tar.*
+*.log
+*.log.*
+*.sig
+pkg/
+src/
+snowcrash/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1a7ebe32398
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Lance Chen <cyen0312@gmail.com>
+
+pkgname=snowcrash
+pkgver=0.16.1.r28.gd4b6e17
+pkgrel=1
+pkgdesc="API Blueprint Parser"
+arch=('i686' 'x86_64')
+url="https://github.com/apiaryio/snowcrash"
+license=('MIT')
+makedepends=('git')
+source=("git+https://github.com/apiaryio/snowcrash")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./configure
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname"
+ ./configure
+ make test
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -m 755 -D "bin/snowcrash" "$pkgdir/usr/bin/snowcrash"
+}