summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEgor Gushcha2024-01-16 00:01:50 +0600
committerEgor Gushcha2024-01-16 00:01:50 +0600
commit04b5f4ab9359f80e3a31a4fc2ead9fc5dcac6afc (patch)
tree840162f81be7621355549cd2dd37e5e8b8b5aa32
downloadaur-04b5f4ab9359f80e3a31a4fc2ead9fc5dcac6afc.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
-rw-r--r--snowflake4
-rw-r--r--snowflake-pt-client-bin.install4
4 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7923478de85f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = snowflake-pt-client-bin
+ pkgdesc = Pluggable Transport using WebRTC, inspired by Flashproxy
+ pkgver = 2.8.1
+ pkgrel = 1
+ url = https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/snowflake
+ install = snowflake-pt-client-bin.install
+ arch = x86_64
+ depends = tor
+ optdepends = tor-browser
+ backup = etc/tor/snowflake
+ source = snowflake-v2.8.1.tar.gz::https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/snowflake/-/jobs/441747/artifacts/raw/snowflake-v2.8.1.tar.gz
+ source = snowflake
+ b2sums = a330fd8f4c8b7858dcdf58865a84f0fda8d3c8ce6b8d2e8e9b50a041349d0e3c8de7f028275bc33344cd1e4060572d64a26b1922f94ad01adc75bacfb2caf057
+ b2sums = 915b0d931ce5766267764bc5355d670f134587b794df07e524ce2c7a35fef097cac7ba037644cdf8887b102139d317090cdfe3cd0d840a8cdee23bc8def0b6bb
+
+pkgname = snowflake-pt-client-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca25638c872e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=snowflake-pt-client-bin
+pkgver=2.8.1
+pkgrel=1
+pkgdesc='Pluggable Transport using WebRTC, inspired by Flashproxy'
+url=https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/snowflake
+arch=(x86_64)
+depends=(tor)
+optdepends=(tor-browser)
+backup=(etc/tor/snowflake)
+install=$pkgname.install
+source=(snowflake-v$pkgver.tar.gz::https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/snowflake/-/jobs/441747/artifacts/raw/snowflake-v$pkgver.tar.gz
+ snowflake)
+
+b2sums=(a330fd8f4c8b7858dcdf58865a84f0fda8d3c8ce6b8d2e8e9b50a041349d0e3c8de7f028275bc33344cd1e4060572d64a26b1922f94ad01adc75bacfb2caf057
+ 915b0d931ce5766267764bc5355d670f134587b794df07e524ce2c7a35fef097cac7ba037644cdf8887b102139d317090cdfe3cd0d840a8cdee23bc8def0b6bb)
+
+package() {
+ install -Dm 755 $srcdir/snowflake-v$pkgver/client/client $pkgdir/usr/bin/snowflake-client
+ install -Dm 644 snowflake $pkgdir/etc/tor/snowflake
+ install -Dm 644 $srcdir/snowflake-v$pkgver/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/snowflake b/snowflake
new file mode 100644
index 000000000000..027da87d2e01
--- /dev/null
+++ b/snowflake
@@ -0,0 +1,4 @@
+ClientTransportPlugin snowflake exec /usr/bin/snowflake-client
+Bridge snowflake 192.0.2.4:80 8838024498816A039FCBBAB14E6F40A0843051FA fingerprint=8838024498816A039FCBBAB14E6F40A0843051FA url=https://snowflake-broker.torproject.net.global.prod.fastly.net/ front=foursquare.com ice=stun:stun.l.google.com:19302,stun:stun.antisip.com:3478,stun:stun.bluesip.net:3478,stun:stun.dus.net:3478,stun:stun.epygi.com:3478,stun:stun.sonetel.net:3478,stun:stun.uls.co.za:3478,stun:stun.voipgate.com:3478,stun:stun.voys.nl:3478 utls-imitate=hellorandomizedalpn
+Bridge snowflake 192.0.2.3:80 2B280B23E1107BB62ABFC40DDCC8824814F80A72 fingerprint=2B280B23E1107BB62ABFC40DDCC8824814F80A72 url=https://snowflake-broker.torproject.net.global.prod.fastly.net/ front=foursquare.com ice=stun:stun.l.google.com:19302,stun:stun.antisip.com:3478,stun:stun.bluesip.net:3478,stun:stun.dus.net:3478,stun:stun.epygi.com:3478,stun:stun.sonetel.com:3478,stun:stun.uls.co.za:3478,stun:stun.voipgate.com:3478,stun:stun.voys.nl:3478 utls-imitate=hellorandomizedalpn
+UseBridges 1
diff --git a/snowflake-pt-client-bin.install b/snowflake-pt-client-bin.install
new file mode 100644
index 000000000000..7f2596ca47b7
--- /dev/null
+++ b/snowflake-pt-client-bin.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo -e "\nThis package includes an example of a snowflake config file"
+ echo -e "Append %include /etc/tor/snowflake to the end of /etc/tor/torrc file to make Tor daemon use it\n"
+}