summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commitb95d02a99ab9c965a46694296c3215a8f1915735 (patch)
tree83e3db586ce1932fb693504e1258e524f8ea9095
downloadaur-b95d02a99ab9c965a46694296c3215a8f1915735.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
-rw-r--r--sntop.install4
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..961cd9d20a8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sntop
+ pkgdesc = Curses-based top-esque console utility for monitoring the connectivity of network hosts
+ pkgver = 1.4.3
+ pkgrel = 1
+ url = http://sntop.sourceforge.net/
+ install = sntop.install
+ arch = i686
+ license = GPL
+ depends = ncurses
+ depends = fping
+ source = http://downloads.sourceforge.net/project/sntop/sntop/1.4.3/sntop-1.4.3.tar.gz
+ sha256sums = 943a5af1905c3ae7ead064e531cde6e9b3dc82598bbda26ed4a43788d81d6d89
+
+pkgname = sntop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37c085a7de9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=sntop
+pkgver=1.4.3
+pkgrel=1
+pkgdesc="Curses-based top-esque console utility for monitoring the connectivity of network hosts"
+arch=('i686')
+url="http://sntop.sourceforge.net/"
+license=('GPL')
+depends=('ncurses' 'fping')
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz)
+sha256sums=('943a5af1905c3ae7ead064e531cde6e9b3dc82598bbda26ed4a43788d81d6d89')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ install -D -m755 $pkgname ${pkgdir}/usr/bin/$pkgname
+ install -D -m644 sntoprc.EXAMPLE ${pkgdir}/usr/share/sntop/sntoprc.EXAMPLE
+ install -D -m644 $pkgname.1 ${pkgdir}/usr/share/man/man1/$pkgname.1
+}
diff --git a/sntop.install b/sntop.install
new file mode 100644
index 000000000000..6b11db9dacb5
--- /dev/null
+++ b/sntop.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "=> See the example configuration file, ammend it to your"
+ echo "=> needs and place in /etc or in your $HOME directory."
+}