summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shurukhin2024-04-17 11:47:39 +0300
committerKonstantin Shurukhin2024-04-17 11:47:39 +0300
commitf1b6b80519838e60e171398f06cd1fddba888853 (patch)
treec501e1db72dcae9cc46be68e049811f45e134a21
parentccf01c0444a4176b86847b14b1b9e6edc84d539f (diff)
downloadaur-f1b6b80519838e60e171398f06cd1fddba888853.tar.gz
add snx-rs.install, add installation of default snx-rs.conf
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rwxr-xr-xsnx-rs.install18
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05b0dbf6a0b4..342c637acba4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = snx-rs-git
pkgdesc = Open source VPN client for Checkpoint security gateways (git version)
- pkgver = 2.0.0.r312.g69578e6
- pkgrel = 2
+ pkgver = 2.0.2.r316.gef76cda
+ pkgrel = 3
url = https://github.com/ancwrd1/snx-rs
+ install = snx-rs.install
arch = x86_64
license = AGPL-3.0
makedepends = cargo
diff --git a/PKGBUILD b/PKGBUILD
index 79c0594204f5..27608780d269 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Konstantin Shurukhin <kshurukhin (at) gmail (dot) com
pkgname=snx-rs-git
_pkgname=snx-rs
-pkgver=2.0.0.r312.g69578e6
-pkgrel=2
+pkgver=2.0.2.r316.gef76cda
+pkgrel=3
pkgdesc="Open source VPN client for Checkpoint security gateways (git version)"
arch=(x86_64)
url=https://github.com/ancwrd1/snx-rs
@@ -20,6 +20,7 @@ source=(
sha256sums=(
'SKIP'
)
+install="snx-rs.install"
pkgver() {
cd ${srcdir}/${_pkgname}
@@ -44,4 +45,5 @@ package() {
install -Dm0755 -t "$pkgdir/usr/bin/" target/release/{snx-rs,snxctl,snx-rs-gui}
sed -i -re 's/^ExecStart.+/ExecStart=snx-rs -m command -l info/g' assets/snx-rs.service
install -Dm0644 -t "$pkgdir/usr/lib/systemd/system/" assets/snx-rs.service
+ install -Dm0644 -t "$pkgdir/usr/share/snx-rs/" assets/snx-rs.conf
}
diff --git a/snx-rs.install b/snx-rs.install
new file mode 100755
index 000000000000..12be003c622f
--- /dev/null
+++ b/snx-rs.install
@@ -0,0 +1,18 @@
+color_msg() {
+ printf "\e[1;33m$@\e[0m\n"
+}
+
+print_msg() {
+ color_msg "\nExample configuration is located in /usr/share/snx-rs/snx-rs.conf"
+ color_msg "You can view all configuration options by running 'snx-rs --help' command"
+ color_msg "If this is clean install, don't forget to enable the service!"
+ color_msg "systemctl enable --now snx-rs\n"
+}
+
+post_install() {
+ print_msg
+}
+
+post_upgrade() {
+ print_msg
+}