summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Doege2015-07-13 17:04:18 +0200
committerMartin Doege2015-07-13 17:04:18 +0200
commita2d2e84e1dc4411475ea0cfd743029b48398c810 (patch)
tree3888d8177e7e10be39f5dfc2c0a36107becaaf85
parentaa3e128f078c44f8307ee6687df31bd0a50179be (diff)
downloadaur-a2d2e84e1dc4411475ea0cfd743029b48398c810.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD42
2 files changed, 29 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6876a282c865..06410ae8e214 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = so-synth-lv2-git
- pkgdesc = LV2 ports of the SO-404, SO-KL5, and SO-666 synthesizers
- pkgver = 20110609.e7ff3d5
- pkgrel = 2
+ pkgdesc = Unofficial LV2 ports of 50m30n3's synthesizers
+ pkgver = 1.4.r174.e7ff3d5
+ pkgrel = 1
+ epoch = 1
url = https://github.com/jeremysalwen/So-synth-LV2
arch = i686
arch = x86_64
- groups = lv2-plugins
license = GPL3
makedepends = git
- depends = libsigc++
- depends = gtkmm
depends = lv2
provides = so-synth-lv2
conflicts = so-synth-lv2
- source = git://github.com/jeremysalwen/So-synth-LV2.git
+ source = so-synth-lv2::git+https://github.com/jeremysalwen/So-synth-LV2.git
md5sums = SKIP
pkgname = so-synth-lv2-git
diff --git a/PKGBUILD b/PKGBUILD
index 66964dbb29f9..2c0ae1e190aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,39 @@
# Maintainer: Martin C. Doege <mdoege at compuserve dot com>
# Contributor: Anh Hai Trinh <anh.hai.trinh@gmail.com>
+# Contributor: Christopher Arndt <chris@chrisarndt.de>
-pkgname=so-synth-lv2-git
-_pkgname=So-synth-LV2
-pkgver=20110609.e7ff3d5
-pkgrel=2
-pkgdesc="LV2 ports of the SO-404, SO-KL5, and SO-666 synthesizers"
-arch=('i686' 'x86_64')
+_pkgname=so-synth-lv2
+pkgname="${_pkgname}-git"
+pkgver=1.4.r174.e7ff3d5
+pkgrel=1
+epoch=1
+pkgdesc="Unofficial LV2 ports of 50m30n3's synthesizers"
+arch=(i686 x86_64)
url="https://github.com/jeremysalwen/So-synth-LV2"
license=('GPL3')
-groups=('lv2-plugins')
-depends=('libsigc++' 'gtkmm' 'lv2')
+depends=('lv2')
makedepends=('git')
-source=("git://github.com/jeremysalwen/So-synth-LV2.git")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/jeremysalwen/So-synth-LV2.git")
md5sums=('SKIP')
-conflicts=("so-synth-lv2")
-provides=("so-synth-lv2")
pkgver() {
- cd "${srcdir}/${_pkgname}"
- git log -1 --format='%cd.%h' --date=short | tr -d -
+ cd "${srcdir}/${_pkgname}"
+
+ ver=$(git tag -l | grep upstream | sort -rn | head -1 | cut -f 2 -d /)
+ echo "$ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/${_pkgname}"
- make
+ cd "${srcdir}/${_pkgname}"
+
+ make
}
-package () {
- cd "${srcdir}/${_pkgname}"
- DESTDIR=$pkgdir make install
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ make DESTDIR="$pkgdir" install
}
+