summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVanya A. Sergeev2016-08-31 05:48:00 -0700
committerVanya A. Sergeev2016-08-31 05:48:00 -0700
commit3d77b3e6491eab764689e174d882320e1dd86d05 (patch)
tree6255b977486e90bbe75f48792682d579abc5c7a4
downloadaur-3d77b3e6491eab764689e174d882320e1dd86d05.tar.gz
Initial release of package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a6222891d6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = soapylms7-git
+ pkgdesc = SoapySDR LMS7002M/LimeSDR Support Module
+ pkgver = r792.4165104
+ pkgrel = 1
+ url = https://github.com/pothosware/SoapySDR
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = Apache
+ makedepends = git
+ makedepends = cmake
+ depends = soapysdr
+ depends = libusb>=1.0
+ depends = sqlite
+ provides = soapylms7
+ conflicts = soapylms7
+ source = soapylms7-git::git+https://github.com/myriadrf/LimeSuite.git
+ sha256sums = SKIP
+
+pkgname = soapylms7-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5455b7da79f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Vanya A. Sergeev <v@sergeev.io>
+pkgname=soapylms7-git
+pkgver=r792.4165104
+pkgrel=1
+pkgdesc="SoapySDR LMS7002M/LimeSDR Support Module"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/pothosware/SoapySDR"
+license=('Apache')
+depends=('soapysdr' 'libusb>=1.0' 'sqlite')
+makedepends=('git' 'cmake')
+provides=('soapylms7')
+conflicts=('soapylms7')
+source=(${pkgname}::"git+https://github.com/myriadrf/LimeSuite.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ mkdir -p build && cd build
+ cmake ../ -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DENABLE_PCIE_XILLYBUS:BOOL=OFF -DENABLE_EVB7COM:BOOL=OFF -DENABLE_EVB7COM:BOOL=OFF -DENABLE_LMS7_GUI:BOOL=OFF -DENABLE_NOVENARF7:BOOL=OFF
+ make -j4
+}
+
+package() {
+ make -C "${srcdir}/${pkgname}/build" DESTDIR="${pkgdir}" install
+ # Install udev rules, changing mode to 666 and ommitting plugdev group
+ mkdir -p "${pkgdir}/etc/udev/rules.d"
+ sed 's/MODE="660", GROUP="plugdev"/MODE="666"/g' "${srcdir}/${pkgname}/udev-rules/64-limesuite.rules" > "${pkgdir}/etc/udev/rules.d/64-limesuite.rules"
+}