summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRihards Skuja2021-02-21 18:33:52 +0200
committerRihards Skuja2021-02-21 18:53:37 +0200
commita17bcf6a737ccf93b9f9e15580a3d97cc3db6cb4 (patch)
treecdf642902e59b5136236ad17f815cb5de65f2a83
parent3ff2da343641aa16c01321cf9ab16b5fe30afcc9 (diff)
downloadaur-a17bcf6a737ccf93b9f9e15580a3d97cc3db6cb4.tar.gz
Fix pkgver, minor cleanup in other places
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c72d641254ca..98e0f514fede 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,7 @@
pkgbase = soapyrtlsdr-git
pkgdesc = SoapySDR RTL-SDR Support Module
- pkgver = 0.2.2.r3.g12aa0a2
+ pkgver = 0.3.2.r1.g8277756
pkgrel = 1
- epoch = 3
url = https://github.com/pothosware/SoapySDR
arch = any
license = MIT
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218620e2fb38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 7e75dd21e8eb..04754ff129c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Masoud <mpoloton@gmail.com>
+# Maintainer: Rihards Skuja <rhssk at posteo dot eu>
+# Contributor: Masoud <mpoloton@gmail.com>
# Contributor: valvetime <valvetimepackages@gmail.com>
# Contributor: Tom Swartz <tom@tswartz.net>
pkgname=soapyrtlsdr-git
-pkgver=0.2.2.r3.g12aa0a2
+pkgver=0.3.2.r1.g8277756
pkgrel=1
-epoch=3
pkgdesc="SoapySDR RTL-SDR Support Module"
arch=('any')
url="https://github.com/pothosware/SoapySDR"
@@ -14,27 +14,24 @@ depends=('soapysdr' 'rtl-sdr')
makedepends=('git' 'cmake')
provides=('soapyrtlsdr')
conflicts=('soapyrtlsdr')
-source=(${pkgname}::"git+https://github.com/pothosware/SoapyRTLSDR.git")
+source=("$pkgname::git+https://github.com/pothosware/SoapyRTLSDR.git")
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git describe --long | sed 's/^soapy.rtlsdr-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/$pkgname"
+ git describe --long | sed 's/^soapy-rtl-sdr-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${pkgname}"
- mkdir -p build
- cd build
- cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cd "$srcdir/$pkgname"
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Wno-dev
+ make -C build
}
package() {
- make -C "${srcdir}/${pkgname}/build" DESTDIR="${pkgdir}" install
-
- # install the license
- mkdir -p "$pkgdir/usr/share/licenses/soapyrtlsdr-git"
- cp "$srcdir/soapyrtlsdr-git/LICENSE.txt" "$pkgdir/usr/share/licenses/soapyrtlsdr-git/"
+ make -C "$srcdir/$pkgname/build" DESTDIR="$pkgdir" install
}