summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChryseus2019-03-19 17:34:03 +0000
committerChryseus2019-03-19 17:35:37 +0000
commit8d4723a8878d72718eeec7abac42cec3bcad8704 (patch)
treecf03ef22950406ed1ce6ae5a0a02534e053dd5f8
downloadaur-8d4723a8878d72718eeec7abac42cec3bcad8704.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..235b2b42b6aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = soapysdrplay
+ pkgdesc = SDRplay support module for SoapySDR
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/pothosware/SoapySDRPlay
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ depends = soapysdr
+ source = https://github.com/pothosware/SoapySDRPlay/archive/soapy-sdrplay-0.2.0.tar.gz
+ sha256sums = 4bf2a73827a575ecf64c8ad1b2a4d9963e78b4726426b7da95959da817719c8c
+
+pkgname = soapysdrplay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7c6df5ec11c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: James Wood (Chryseus) <Chryseus8080@gmail.com>
+
+pkgname=soapysdrplay
+_pkgname=SoapySDRPlay
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="SDRplay support module for SoapySDR"
+arch=('x86_64')
+url="https://github.com/pothosware/SoapySDRPlay"
+license=('MIT')
+depends=('soapysdr')
+makedepends=('cmake')
+source=("https://github.com/pothosware/SoapySDRPlay/archive/soapy-sdrplay-0.2.0.tar.gz")
+sha256sums=('4bf2a73827a575ecf64c8ad1b2a4d9963e78b4726426b7da95959da817719c8c')
+
+build() {
+mkdir -p "$_pkgname"-soapy-sdrplay-0.2.0/build
+cd "$_pkgname"-soapy-sdrplay-0.2.0/build
+
+cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+make
+}
+
+package() {
+ cd "$_pkgname"-soapy-sdrplay-0.2.0/build
+ make DESTDIR="$pkgdir" install
+}
+