summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel YC Lin2015-06-13 14:20:59 +0800
committerDaniel YC Lin2015-06-13 14:20:59 +0800
commitde1f6df55d57abdff3e3b8a5b45ea693795656c7 (patch)
treeef835fb82700dfd1f139bd7dcedefe90e14c225e
parentfdecf2dd4b1fed8812277249cbbcbcb03661ad32 (diff)
downloadaur-de1f6df55d57abdff3e3b8a5b45ea693795656c7.tar.gz
use rXXX as version number
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9cf647eec40..7b9060778b93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel YC Lin <dlin.tw@gmail.com>
pkgname=sockperf-git
-pkgver=257
+pkgver=r145.e12372b
pkgrel=1
pkgdesc='A benchmarking utility for measuring network performance (latency and throughput) over socket API, with focus on high performance systems'
url='https://github.com/mellanox/sockperf'
@@ -13,7 +13,7 @@ depends=('bash' gawk )
makedepends=(doxygen)
pkgver() {
cd repo
- git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
cd repo