summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-03-23 19:27:08 +0200
committerDimitris Kiziridis2020-03-23 19:27:08 +0200
commit01e2336db4da9f4c9138a4ebcbc0642df59f1dd3 (patch)
tree6c685442fe7c47daa4516bc5b5399b249c55180a
downloadaur-01e2336db4da9f4c9138a4ebcbc0642df59f1dd3.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41a5548cec98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = socli
+ pkgdesc = Stack overflow command line client. Search and browse stack overflow without leaving the terminal
+ pkgver = 3.8
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/socli
+ arch = any
+ license = BSD-3-Clause
+ makedepends = python-setuptools
+ depends = python-beautifulsoup4
+ depends = python-requests
+ depends = python-colorama
+ depends = python-py-stackexchange
+ depends = python-urwid
+ source = https://github.com/gautamkrishnar/socli/archive/3.8.tar.gz
+ md5sums = d7b9260ce21e0c5815ac1095a058ca23
+
+pkgname = socli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75a731d34e56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=socli
+pkgver=3.8
+pkgrel=1
+pkgdesc="Stack overflow command line client. Search and browse stack overflow without leaving the terminal"
+arch=('any')
+url='https://pypi.python.org/pypi/socli'
+license=('BSD-3-Clause')
+depends=('python-beautifulsoup4'
+ 'python-requests'
+ 'python-colorama'
+ 'python-py-stackexchange'
+ 'python-urwid')
+makedepends=('python-setuptools')
+source=("https://github.com/gautamkrishnar/socli/archive/${pkgver}.tar.gz")
+md5sums=('d7b9260ce21e0c5815ac1095a058ca23')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+} \ No newline at end of file