summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Tryfonidis2015-06-27 16:23:25 +0300
committerTom Tryfonidis2015-06-27 16:23:25 +0300
commit28d817f177222832fa906c513c99e885401dbcd1 (patch)
tree6c10ed676107162929c63ed8472e260011e4a4f2
downloadaur-28d817f177222832fa906c513c99e885401dbcd1.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD43
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..554c6281274d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = socnetv-git
+ pkgdesc = Social Networks Analysis and Visualisation (Development version)
+ pkgver = 1.6.r112.g4279da4
+ pkgrel = 1
+ url = http://socnetv.sourceforge.net/
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ provides = socnetv-git
+ conflicts = socnetv
+ source = socnetv::git://git.code.sf.net/p/socnetv/git#branch=develop
+ md5sums = SKIP
+
+pkgname = socnetv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..9d28c37e41cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+#Contributor: Tom Tryfonidis <tomtryf [at] gmail [dot] com>
+#Maintainer: Tom Tryfonidis <tomtryf [at] gmail [dot] com>
+
+_pkgname=socnetv
+pkgname=$_pkgname-git
+pkgver=1.6.r112.g4279da4
+pkgrel=1
+pkgdesc="Social Networks Analysis and Visualisation (Development version)"
+arch=('any')
+url="http://socnetv.sourceforge.net/"
+license=('GPL3')
+depends=('qt5-base')
+makedepends=('git')
+provides=('socnetv-git')
+conflicts=('socnetv')
+source=("$_pkgname::git://git.code.sf.net/p/socnetv/git#branch=develop")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/$_pkgname"
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/$_pkgname"
+
+ qmake-qt5
+ make
+}
+
+package() {
+ cd "${srcdir}/$_pkgname"
+
+ install -d "$pkgdir/usr/share/doc/socnetv/"
+ install -d "$pkgdir/usr/share/socnetv/"
+ install -D socnetv "$pkgdir/usr/bin/socnetv"
+ install -D socnetv.desktop "$pkgdir/usr/share/applications/socnetv.desktop"
+ install -D "src/images/socnetv.png" "$pkgdir/usr/share/pixmaps/socnetv.png"
+ install -D "man/socnetv.1.gz" "$pkgdir/usr/share/man/man1/socnetv.1.gz"
+
+ cp -r translations/ "$pkgdir/usr/share/socnetv/"
+ cp -r manual/ "$pkgdir/usr/share/doc/socnetv/"
+}