summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Hitchcock2016-06-22 22:19:12 -0500
committerDoug Hitchcock2016-06-22 22:19:12 -0500
commitc65bc707d9a993bc33b23b6b4cd95b5e6f5ac83d (patch)
tree931fd438896c86280ddc2a0548eb9af40ea70a57
downloadaur-c65bc707d9a993bc33b23b6b4cd95b5e6f5ac83d.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..181ae6b02994
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = sococo
+ pkgdesc = Sococo for Linux
+ pkgver = 0.3.9_9510
+ pkgrel = 1
+ url = https://app.sococo.com/a/download
+ arch = x86_64
+ license = custom
+ source_x86_64 = https://s.sococo.com/rs/client/linux64/apt/pool/main/sococo-0.3.9-9510_amd64.deb
+ sha256sums_x86_64 = e9dfa546f359f781c23176b641f812160c7784a19a1baf2bb3177ef4a6c4f494
+
+pkgname = sococo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f0dd861918b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: "purplerhino" Douglas Hitchcock <clarkaddison(at)gmail(dot)com>
+
+pkgname=sococo
+pkgver=0.3.9_9510
+pkgrel=1
+pkgdesc="Sococo for Linux"
+arch=('x86_64')
+url="https://app.sococo.com/a/download"
+license=('custom')
+
+source_x86_64=("https://s.sococo.com/rs/client/linux64/apt/pool/main/sococo-${pkgver//_/-}_amd64.deb")
+
+sha256sums_x86_64=('e9dfa546f359f781c23176b641f812160c7784a19a1baf2bb3177ef4a6c4f494')
+
+package() {
+ bsdtar -O -xf "sococo-${pkgver//_/-}"*.deb data.tar.gz | bsdtar -C "$pkgdir" -xJf -
+
+ # Permission fix
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+
+ # Move license
+ install -dm755 ${pkgdir}/usr/share/licenses/${pkgname}
+ mv ${pkgdir}/usr/share/sococo/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}
+ ln -s ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE ${pkgdir}/usr/share/sococo/LICENSE
+}