summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHeiko Nickerl2021-08-02 21:14:02 +0200
committerHeiko Nickerl2021-08-02 21:14:02 +0200
commit9ba571d0f17f20c2e7ba8c850d3674020946cf61 (patch)
treefc8f6603adac0e6af56a6b48d354a6c6acd4bfc1
parentcc8d5ca6ae432be35b03b7bb15108b22c5b1d3ac (diff)
downloadaur-9ba571d0f17f20c2e7ba8c850d3674020946cf61.tar.gz
Update to v0.20.5
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD34
2 files changed, 28 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db90d89084f4..b471e017fe56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,10 @@
pkgbase = sodalite
pkgdesc = Keyboard-driven terminal file navigator and launcher
- pkgver = 0.20.0
+ pkgver = 0.21.2
pkgrel = 1
url = https://www.github.com/hnicke/sodalite
arch = any
license = GPL
- makedepends = git
- makedepends = awk
depends = python>=3.9
depends = python-binaryornot
depends = python-urwid
@@ -17,8 +15,7 @@ pkgbase = sodalite
depends = python-click
depends = python-blinker
depends = xdg-utils
- backup = etc/sodalite.conf
- source = sodalite-0.20.0.tar.gz::https://github.com/hnicke/sodalite/archive/v0.20.0.tar.gz
- sha256sums = abd9b68f9838a938862881c81d3acc72dcb6ade51ded432fabd0a52c3aca4de9
+ source = https://files.pythonhosted.org/packages/source/s/sodalite/sodalite-0.21.2.tar.gz
+ sha256sums = a95e95938b27def8586b3cfccee855ef2e415f0f0175551e83e1da603af80cb0
pkgname = sodalite
diff --git a/PKGBUILD b/PKGBUILD
index 155ff6ea11e9..cd3f4691da0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
# Maintainer: Heiko Nickerl <dev at heiko-nickerl dot com>
pkgname=sodalite
-pkgver=0.20.0
+pkgver=0.21.2
pkgrel=1
pkgdesc="Keyboard-driven terminal file navigator and launcher"
arch=('any')
url="https://www.github.com/hnicke/sodalite"
license=('GPL')
-makedepends=('git' 'awk')
depends=(
'python>=3.9'
'python-binaryornot'
@@ -19,13 +18,30 @@ depends=(
'python-blinker'
'xdg-utils'
)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/hnicke/sodalite/archive/v$pkgver.tar.gz")
-backup=('etc/sodalite.conf')
-sha256sums=('abd9b68f9838a938862881c81d3acc72dcb6ade51ded432fabd0a52c3aca4de9')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/${pkgname//-/_}-$pkgver.tar.gz")
+sha256sums=('a95e95938b27def8586b3cfccee855ef2e415f0f0175551e83e1da603af80cb0')
+
+build() {
+ cd $pkgname-$pkgver
+ python setup.py build
+}
-_gitroot=https://github.com/hnicke/$pkgname.git
package() {
- cd "${srcdir}/$pkgname-$pkgver"
- make sysconfdir=/etc prefix=/usr DESTDIR="$pkgdir" install
-}
+ cd $pkgname-$pkgver
+ python setup.py install \
+ --root="$pkgdir" \
+ --optimize=1 \
+ --skip-build
+ install -Dm644 sodalite.desktop "$pkgdir/usr/share/applications/sodalite.desktop"
+ install -Dm644 docs/sodalite.1 "$pkgdir/usr/share/man/man1/sodalite.1"
+ install -Dm644 docs/sodalite-open.1 "$pkgdir/usr/share/man/man1/sodalite-open.1"
+ install -Dm644 docs/sodalite-open.1 "$pkgdir/usr/share/man/man1/sodalite-open.1"
+ install -Dm755 scripts/sodalite-open "$pkgdir/usr/bin/sodalite-open"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/sodalite/README"
+ install -Dm644 copyright "$pkgdir/usr/share/doc/sodalite/copyright"
+ install -Dm644 CHANGELOG.md "$pkgdir/usr/share/doc/sodalite/changelog"
+ install -Dm644 scripts/shell-integration.sh "$pkgdir/usr/share/sodalite/shell-integration.sh"
+ install -Dm644 scripts/shell-integration.fish "$pkgdir/usr/share/sodalite/shell-integration.fish"
+ install -Dm644 sodalite/core/sodalite.conf "$pkgdir/usr/share/sodalite/sodalite.conf"
+}