summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHeiko Nickerl2018-02-12 19:25:36 +0100
committerHeiko Nickerl2018-02-12 19:25:36 +0100
commitc40f4585be6c9904dd3b73091322179a71b4d264 (patch)
tree9a894bd5d61c42fe834e81742eed48ea3c655002
downloadaur-c40f4585be6c9904dd3b73091322179a71b4d264.tar.gz
First version of sodalite
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--sodalite.install11
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf36ae96577b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = sodalite-git
+ pkgdesc = Keyboard-driven terminal file navigator and launcher
+ pkgver = r45.ece430f
+ pkgrel = 1
+ url = www.github.com/hnicke/sodalite
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = awk
+ depends = python-binaryornot
+ depends = python-npyscreen-git
+ depends = sqlite
+ source = git+https://github.com/hnicke/sodalite.git
+ md5sums = SKIP
+
+pkgname = sodalite-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d5a8461d77b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Heiko Nickerl <dev at heiko-nickerl dot com>
+pkgname="sodalite-git"
+pkgver=r45.ece430f
+pkgrel=1
+pkgdesc="Keyboard-driven terminal file navigator and launcher"
+arch=('any')
+url="www.github.com/hnicke/sodalite"
+license=('GPL')
+makedepends=('git' 'awk' )
+depends=('python-binaryornot' 'python-npyscreen-git' 'sqlite' )
+source=('git+https://github.com/hnicke/sodalite.git')
+md5sums=('SKIP')
+install=sodalite.install
+
+_gitroot=https://github.com/hnicke/sodalite.git
+_gitname=sodalite
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/$_gitname"
+ echo pkgdir is $pkgdir
+ FAKE_ROOT=$pkgdir ./install
+}
diff --git a/sodalite.install b/sodalite.install
new file mode 100644
index 000000000000..654d403214d0
--- /dev/null
+++ b/sodalite.install
@@ -0,0 +1,11 @@
+# arg 1: the new package version
+post_install() {
+ bold=$(tput bold)
+ normal=$(tput sgr0)
+ echo "
+ ===> For proper ${bold}shell integration ${normal}(supported: bash, zsh), add following line to your .bashrc/.zshrc:
+
+ ${bold}source /usr/share/sodalite/shell-integration.sh
+
+ "
+}