summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatteo De Carlo2017-09-25 13:44:01 +0200
committerMatteo De Carlo2017-09-25 13:44:01 +0200
commit70c15f08246ff41d4b858657be0bb5afedb2b1eb (patch)
tree48dfe957e012838066c14dea9a33aca532490c7a
downloadaur-70c15f08246ff41d4b858657be0bb5afedb2b1eb.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdd5bad63e32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Sep 25 11:37:35 UTC 2017
+pkgbase = sodium-git
+ pkgdesc = Application automation framework that allows you to build applications that have automation built-in
+ pkgver = 0.1.0.319.3bb1da3
+ pkgrel = 1
+ url = https://github.com/redox-os/sodium
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ depends = sdl2
+ provides = sodium
+ conflicts = sodium-bin
+ conflicts = sodium
+ source = sodium-git::git+https://github.com/redox-os/sodium.git
+ sha256sums = SKIP
+
+pkgname = sodium-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66e31ff3d98c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Matteo De Carlo <matteo.dek@gmail.com>
+
+pkgname=sodium-git
+pkgver=0.1.0.319.3bb1da3
+pkgrel=1
+pkgdesc="Application automation framework that allows you to build applications that have automation built-in"
+arch=('x86_64')
+url="https://github.com/redox-os/sodium"
+license=('MIT')
+depends=('sdl2')
+makedepends=('cargo')
+provides=('sodium')
+conflicts=('sodium-bin' 'sodium')
+source=("${pkgname}::git+https://github.com/redox-os/sodium.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ echo -n $(grep version Cargo.toml| sed 's/version = "\(.*\)"/\1./')
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ # Use a temporary local Cargo repository.
+ export CARGO_HOME="${srcdir}/cargo-repository"
+
+ cd "${srcdir}/${pkgname}"
+ cargo build --release
+}
+
+# no tests available
+#check() {
+# # Use a temporary local Cargo repository.
+# export CARGO_HOME="$srcdir/cargo-repository"
+#
+# cd "${srcdir}/${pkgname}"
+# cargo test
+#}
+
+package() {
+ install -D -m755 "${srcdir}/${pkgname}/target/release/sodium" "${pkgdir}/usr/bin/sodium"
+}
+