summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoelof Rietbroek2018-04-16 22:08:39 +0200
committerRoelof Rietbroek2018-04-16 22:08:39 +0200
commit2f31dd1414f4aabee86f12e754db05c346eb6c1d (patch)
treee2d72c0b63d88452558f2d7c7a429d6c782f749f
downloadaur-2f31dd1414f4aabee86f12e754db05c346eb6c1d.tar.gz
first setup
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
-rw-r--r--makefile.patch20
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47688f4e6ff8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sofa-shared
+ pkgdesc = Set of algorithms and procedures used in fundamental astronomy (shared C-library version)
+ pkgver = 20180130
+ pkgrel = 1
+ url = http://www.iausofa.org
+ arch = x86_64
+ arch = i686
+ license = SOFA license
+ source = http://www.iausofa.org/2018_0130_C/sofa_c-20180130.tar.gz
+ source = makefile.patch
+ md5sums = 9d6903c7690e84a788b622fba6f10146
+ md5sums = fe06c75a994a6dd11ef082361b4bb968
+
+pkgname = sofa-shared
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..00aba4bea69e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*tar.gz
+*xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d0abf4a63cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Médéric Boquien <mboquien@free.fr>
+# Contributor: Roelof Rietbroek <roelof@wobbly.earth>
+pkgname=sofa-shared
+pkgver=20180130
+pkgrel=1
+pkgdesc="Set of algorithms and procedures used in fundamental astronomy (shared C-library version)"
+url="http://www.iausofa.org"
+arch=('x86_64' 'i686')
+license=('SOFA license')
+source=("http://www.iausofa.org/2018_0130_C/sofa_c-${pkgver}.tar.gz" "makefile.patch")
+md5sums=('9d6903c7690e84a788b622fba6f10146'
+ 'fe06c75a994a6dd11ef082361b4bb968')
+
+prepare() {
+ cd ${srcdir}
+ patch "sofa/${pkgver}/c/src/makefile" makefile.patch
+
+}
+
+
+build() {
+ cd "${srcdir}/sofa/${pkgver}/c/src"
+ make CFLAGF="-c -O -fPIC"
+}
+
+package() {
+ cd "${srcdir}/sofa/${pkgver}/c/src"
+ make INSTALL_DIR="${pkgdir}/usr" install
+
+ cd "${srcdir}/sofa/${pkgver}/c/"
+ install -Dm644 00READ.ME "$pkgdir/usr/share/doc/sofa/00READ.ME"
+ install -m644 doc/*.lis "$pkgdir/usr/share/doc/sofa/"
+}
+
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..bf72064319b8
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,20 @@
+--- tmp/sofa/20180130/c/src/makefile 2018-01-30 14:47:22.000000000 +0100
++++ makefilemodrr 2018-04-16 21:24:19.725749771 +0200
+@@ -77,7 +77,7 @@
+
+ # Name the SOFA/C library in its source and target locations.
+
+-SOFA_LIB_NAME = libsofa_c.a
++SOFA_LIB_NAME = libsofa_c.so
+ SOFA_LIB = $(SOFA_LIB_DIR)$(SOFA_LIB_NAME)
+
+ # Name the SOFA/C testbed in its source and target locations.
+@@ -380,7 +380,7 @@
+
+ # Build the library.
+ $(SOFA_LIB_NAME): $(SOFA_OBS)
+- ar ru $(SOFA_LIB_NAME) $?
++ gcc -shared -o $(SOFA_LIB_NAME) $?
+
+ # Install the header files.
+ $(SOFA_INC) : $(INSTALL_DIRS) $(SOFA_INC_NAMES)