summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2021-03-31 20:58:27 -0600
committerBrian Bidulock2021-03-31 20:58:27 -0600
commit48fd7e9ffd1a874eb677d9e31b90985105e9c2f4 (patch)
tree4dc718f6ca991d0349983757397480b048ba3b61
parent53cdadae64fbe665473e472143dccc14d5710946 (diff)
downloadaur-48fd7e9ffd1a874eb677d9e31b90985105e9c2f4.tar.gz
uppkg
-rw-r--r--.SRCINFO12
-rw-r--r--0001-fix-buggy-loop-hack.patch36
-rw-r--r--PKGBUILD17
3 files changed, 13 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7911e428fc6..077efddfa2e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = sofia-sip
pkgdesc = An open-source SIP User-Agent library
- pkgver = 1.12.11
- pkgrel = 4
+ pkgver = 1.13.3
+ pkgrel = 1
url = http://sofia-sip.sourceforge.net
arch = x86_64
arch = i686
license = LGPL
depends = glib2
depends = openssl
- options = zipman
- source = http://downloads.sourceforge.net/sofia-sip/sofia-sip-1.12.11.tar.gz
- source = 0001-fix-buggy-loop-hack.patch
- md5sums = f3582c62080eeecd3fa4cd5d4ccb4225
- md5sums = ad26f31dec412906443823f10e2fdab0
+ depends = gawk
+ source = sofia-sip-1.13.3.tar.gz::https://github.com/freeswitch/sofia-sip/archive/refs/tags/v1.13.3.tar.gz
+ md5sums = f6805ecb2d46c04ef51efddd8a991fff
pkgname = sofia-sip
diff --git a/0001-fix-buggy-loop-hack.patch b/0001-fix-buggy-loop-hack.patch
deleted file mode 100644
index ec9acb4259f0..000000000000
--- a/0001-fix-buggy-loop-hack.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -up sofia-sip-1.12.11/libsofia-sip-ua/msg/msg_parser.c.orig sofia-sip-1.12.11/libsofia-sip-ua/msg/msg_parser.c
---- sofia-sip-1.12.11/libsofia-sip-ua/msg/msg_parser.c.orig 2011-03-11 07:49:18.000000000 -0700
-+++ sofia-sip-1.12.11/libsofia-sip-ua/msg/msg_parser.c 2020-05-08 20:06:12.690000000 -0600
-@@ -2468,8 +2468,6 @@ int msg_header_prepend(msg_t *msg,
- msg_header_t **
- msg_hclass_offset(msg_mclass_t const *mc, msg_pub_t const *mo, msg_hclass_t *hc)
- {
-- int i;
--
- assert(mc && hc);
-
- if (mc == NULL || hc == NULL)
-@@ -2484,9 +2482,20 @@ msg_hclass_offset(msg_mclass_t const *mc
- }
- else
- /* Header has no name. */
-- for (i = 0; i <= 6; i++)
-- if (hc->hc_hash == mc->mc_request[i].hr_class->hc_hash)
-- return (msg_header_t **)((char *)mo + mc->mc_request[i].hr_offset);
-+ if (hc->hc_hash == mc->mc_request[0].hr_class->hc_hash)
-+ return (msg_header_t **)((char *)mo + mc->mc_request[0].hr_offset);
-+ else if (hc->hc_hash == mc->mc_status[0].hr_class->hc_hash)
-+ return (msg_header_t **)((char *)mo + mc->mc_status[0].hr_offset);
-+ else if (hc->hc_hash == mc->mc_separator[0].hr_class->hc_hash)
-+ return (msg_header_t **)((char *)mo + mc->mc_separator[0].hr_offset);
-+ else if (hc->hc_hash == mc->mc_payload[0].hr_class->hc_hash)
-+ return (msg_header_t **)((char *)mo + mc->mc_payload[0].hr_offset);
-+ else if (hc->hc_hash == mc->mc_unknown[0].hr_class->hc_hash)
-+ return (msg_header_t **)((char *)mo + mc->mc_unknown[0].hr_offset);
-+ else if (hc->hc_hash == mc->mc_error[0].hr_class->hc_hash)
-+ return (msg_header_t **)((char *)mo + mc->mc_error[0].hr_offset);
-+ else if (hc->hc_hash == mc->mc_multipart[0].hr_class->hc_hash)
-+ return (msg_header_t **)((char *)mo + mc->mc_multipart[0].hr_offset);
-
- return NULL;
- }
diff --git a/PKGBUILD b/PKGBUILD
index 28fd49fc1db2..caed22e5520c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,26 @@
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Bjorn Lindeijer <bjorn lindeijer nl>
pkgname=sofia-sip
-pkgver=1.12.11
-pkgrel=4
+pkgver=1.13.3
+pkgrel=1
pkgdesc="An open-source SIP User-Agent library"
arch=('x86_64' 'i686')
url="http://sofia-sip.sourceforge.net"
-options=('zipman')
license=('LGPL')
-depends=('glib2' 'openssl')
-source=(http://downloads.sourceforge.net/sofia-sip/${pkgname}-${pkgver}.tar.gz
- 0001-fix-buggy-loop-hack.patch)
-md5sums=('f3582c62080eeecd3fa4cd5d4ccb4225'
- 'ad26f31dec412906443823f10e2fdab0')
+depends=('glib2' 'openssl' 'gawk')
+source=($pkgname-$pkgver.tar.gz::https://github.com/freeswitch/$pkgname/archive/refs/tags/v$pkgver.tar.gz)
+md5sums=('f6805ecb2d46c04ef51efddd8a991fff')
prepare() {
cd $pkgname-$pkgver
- patch -p1 -N -b -z .orig <../0001-fix-buggy-loop-hack.patch
+ ./autogen.sh
}
build() {
cd $pkgname-$pkgver
./configure --prefix=/usr --with-openssl
+ # Fight unused direct deps
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
make
}