summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-01-13 17:37:33 -0500
committerGuillaume Horel2019-01-13 17:37:33 -0500
commit6712f53ff971f1eda7b15c69624efb5965572580 (patch)
tree84c605bcb978a08951826231b14356a3ebae2dde
parent5f73de21ae28623bda1ec7caffb7ede9eada81b9 (diff)
downloadaur-6712f53ff971f1eda7b15c69624efb5965572580.tar.gz
version bump
-rw-r--r--.SRCINFO9
-rw-r--r--279f184bc9972778ce9c1eb1c46ae67d5705f66b.patch53
-rw-r--r--PKGBUILD15
3 files changed, 69 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9514aa7d9dd7..f5267601632a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = sofia-sip-bc
pkgdesc = An open-source SIP User-Agent library
- pkgver = 1.13.16bc
+ pkgver = 1.13.25bc
pkgrel = 1
url = http://sofia-sip.sourceforge.net
- arch = i686
arch = x86_64
license = LGPL
depends = glib2
@@ -11,8 +10,10 @@ pkgbase = sofia-sip-bc
provides = sofia-sip
conflicts = sofia-sip
options = zipman
- source = https://github.com/BelledonneCommunications/sofia-sip/archive/1.13.16bc.tar.gz
- sha256sums = f359e383ed56706285b192853c000cb45c2fa3e020a1e24df696396ba6ac5c19
+ source = https://github.com/BelledonneCommunications/sofia-sip/archive/1.13.25bc.tar.gz
+ source = 279f184bc9972778ce9c1eb1c46ae67d5705f66b.patch
+ sha256sums = 0200c3c29b17a8a1418ad02bf8c4b09bc1d66ee2e65952fbef203624a2c27b1a
+ sha256sums = 2a9abf5437fb1b2616aa4f090965229d84b62a14084d3cecdc6b9906e1adfee9
pkgname = sofia-sip-bc
diff --git a/279f184bc9972778ce9c1eb1c46ae67d5705f66b.patch b/279f184bc9972778ce9c1eb1c46ae67d5705f66b.patch
new file mode 100644
index 000000000000..f806345be39d
--- /dev/null
+++ b/279f184bc9972778ce9c1eb1c46ae67d5705f66b.patch
@@ -0,0 +1,53 @@
+From 279f184bc9972778ce9c1eb1c46ae67d5705f66b Mon Sep 17 00:00:00 2001
+From: Simon Morlat <simon.morlat@linphone.org>
+Date: Tue, 24 Apr 2018 16:18:53 +0200
+Subject: [PATCH] Add accessor to know if a tport is server.
+
+---
+ configure.ac | 2 +-
+ libsofia-sip-ua/tport/sofia-sip/tport.h | 3 +++
+ libsofia-sip-ua/tport/tport.c | 4 ++++
+ 3 files changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 47a2d615..8ad82e04 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -11,7 +11,7 @@ dnl information on the package
+ dnl ---------------------------
+
+ dnl update both the version for AC_INIT and the LIBSOFIA_SIP_UA_MAJOR_MINOR
+-AC_INIT([sofia-sip], [1.13.24bc])
++AC_INIT([sofia-sip], [1.13.25bc])
+ AC_CONFIG_SRCDIR([libsofia-sip-ua/sip/sofia-sip/sip.h])
+ AC_CONFIG_MACRO_DIR([m4])
+ AC_SUBST(VER_LIBSOFIA_SIP_UA_MAJOR_MINOR, [1.13])
+diff --git a/libsofia-sip-ua/tport/sofia-sip/tport.h b/libsofia-sip-ua/tport/sofia-sip/tport.h
+index 9b92a6fd..3b76a99b 100644
+--- a/libsofia-sip-ua/tport/sofia-sip/tport.h
++++ b/libsofia-sip-ua/tport/sofia-sip/tport.h
+@@ -380,6 +380,9 @@ TPORT_DLL void tport_set_user_data(tport_t *self, void* data);
+ /** Get Data from tport */
+ TPORT_DLL void* tport_get_user_data(tport_t *self);
+
++/** Return TRUE if underlying connection was server (created by accept()), FALSE otherwise*/
++TPORT_DLL int tport_is_server(tport_t *self);
++
+ /* ---------------------------------------------------------------------- */
+ /* SigComp-related functions */
+
+diff --git a/libsofia-sip-ua/tport/tport.c b/libsofia-sip-ua/tport/tport.c
+index 84ccfafe..05ca1209 100644
+--- a/libsofia-sip-ua/tport/tport.c
++++ b/libsofia-sip-ua/tport/tport.c
+@@ -943,6 +943,10 @@ tport_t *tport_alloc_secondary(tport_primary_t *pri,
+ return self;
+ }
+
++int tport_is_server(tport_t *self){
++ return self->tp_accepted;
++}
++
+
+ /** Create a connected transport object with socket.
+ *
diff --git a/PKGBUILD b/PKGBUILD
index 7287ac7dc531..5f242cee73e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,25 @@
# Maintainer : Guillaume Horel <guillaume.horel@gmail.com>
_pkgname=sofia-sip
pkgname=sofia-sip-bc
-pkgver=1.13.16bc
+pkgver=1.13.25bc
pkgrel=1
pkgdesc="An open-source SIP User-Agent library"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://sofia-sip.sourceforge.net"
options=('zipman')
license=('LGPL')
depends=('glib2' 'openssl')
provides=('sofia-sip')
conflicts=('sofia-sip')
-source=("https://github.com/BelledonneCommunications/sofia-sip/archive/$pkgver.tar.gz")
-sha256sums=('f359e383ed56706285b192853c000cb45c2fa3e020a1e24df696396ba6ac5c19')
+source=("https://github.com/BelledonneCommunications/sofia-sip/archive/$pkgver.tar.gz"
+ "279f184bc9972778ce9c1eb1c46ae67d5705f66b.patch")
+sha256sums=('0200c3c29b17a8a1418ad02bf8c4b09bc1d66ee2e65952fbef203624a2c27b1a'
+ '2a9abf5437fb1b2616aa4f090965229d84b62a14084d3cecdc6b9906e1adfee9')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ patch -p1 < "../279f184bc9972778ce9c1eb1c46ae67d5705f66b.patch"
+}
build() {
cd "$_pkgname-$pkgver"