summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-08 22:19:09 +0800
committerzxp198210052024-01-08 22:19:09 +0800
commitf366d172446637e49dcd78520ee55228c63c7464 (patch)
treed767a50bc1803bbd0bf18dc2ade935140e2612a6
parentff34c8fe16f1f5f2cdd3aa472dc740098711981b (diff)
downloadaur-f366d172446637e49dcd78520ee55228c63c7464.tar.gz
update to 0.3.3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
-rw-r--r--sofie-chef.sh22
3 files changed, 35 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e36cf36d508b..7c9a3ef35b8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,22 @@
pkgbase = sofie-chef-bin
pkgdesc = Disrupting the industry & stirring pots
- pkgver = 0.3.2
+ pkgver = 0.3.3
pkgrel = 1
url = https://github.com/nrkno/sofie-chef
arch = x86_64
license = MIT
makedepends = squashfuse
depends = electron26
- depends = libx11
- depends = gdk-pixbuf2
- depends = libxext
+ depends = dbus-glib
depends = libdbusmenu-glib
depends = gtk2
- depends = dbus-glib
- provides = sofie-chef=0.3.2
+ provides = sofie-chef=0.3.3
conflicts = sofie-chef
- source = sofie-chef-0.3.2.AppImage::https://github.com/nrkno/sofie-chef/releases/download/v0.3.2/SofieChef-0.3.2-Linux-Executable.AppImage
- source = LICENSE::https://raw.githubusercontent.com/nrkno/sofie-chef/v0.3.2/LICENSE
+ source = sofie-chef-0.3.3.AppImage::https://github.com/nrkno/sofie-chef/releases/download/v0.3.3/SofieChef-0.3.3-Linux-Executable.AppImage
+ source = LICENSE-0.3.3::https://raw.githubusercontent.com/nrkno/sofie-chef/v0.3.3/LICENSE
source = sofie-chef.sh
- sha256sums = 7662d1f78877f7ff735edf57b0c71d7dc5efb2ffecd8ec68edda5ae17b3ae66c
- sha256sums = 1885e72fa406407f4135fc914d88aa7b07a74c2a0ce891f74b0224919d6ee57d
- sha256sums = 7bbf487149e8c0900124e0b51915957e6a8b87eae918837753ece15b3adab5bd
+ sha256sums = 913f848d292ab514b0f241d63e3e7c6ff7968fbf096977f821aea39193d0d9e2
+ sha256sums = ac26e60681c9ba6ec5eddf9b1afa3442d8ada9d77fe42b4515c42a2a15392c44
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
pkgname = sofie-chef-bin
diff --git a/PKGBUILD b/PKGBUILD
index 4eefb5260666..080a33d8d4ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=sofie-chef-bin
_appname=SofieChef
-pkgver=0.3.2
+pkgver=0.3.3
+_electronversion=26
pkgrel=1
pkgdesc="Disrupting the industry & stirring pots"
arch=('x86_64')
@@ -10,40 +11,36 @@ license=("MIT")
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=(
- 'electron26'
- #'hicolor-icon-theme'
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
+ "electron${_electronversion}"
+ 'dbus-glib'
'libdbusmenu-glib'
'gtk2'
- 'dbus-glib'
)
makedepends=(
'squashfuse'
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${_appname}-${pkgver}-Linux-Executable.AppImage"
- "LICENSE::https://raw.githubusercontent.com/nrkno/sofie-chef/v${pkgver}/LICENSE"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/nrkno/sofie-chef/v${pkgver}/LICENSE"
"${pkgname%-bin}.sh"
)
-sha256sums=('7662d1f78877f7ff735edf57b0c71d7dc5efb2ffecd8ec68edda5ae17b3ae66c'
- '1885e72fa406407f4135fc914d88aa7b07a74c2a0ce891f74b0224919d6ee57d'
- '7bbf487149e8c0900124e0b51915957e6a8b87eae918837753ece15b3adab5bd')
+sha256sums=('913f848d292ab514b0f241d63e3e7c6ff7968fbf096977f821aea39193d0d9e2'
+ 'ac26e60681c9ba6ec5eddf9b1afa3442d8ada9d77fe42b4515c42a2a15392c44'
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
- #for _icons in 16x16 32x32 48x48 64x64 128x128 256x256;do
- # install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
- # -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
- #done
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file
diff --git a/sofie-chef.sh b/sofie-chef.sh
index a424b6e2a448..aacd8f895847 100644
--- a/sofie-chef.sh
+++ b/sofie-chef.sh
@@ -1,11 +1,15 @@
-#!/bin/bash
-_ELECTRON=/usr/bin/electron26
-APPDIR="/usr/lib/sofie-chef"
-export PATH="${APPDIR}:${PATH}"
-export LD_LIBRARY_PATH="${APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${APPDIR}/app.asar"
+#!/bin/sh
+set -e
+_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} "$@"
+ exec electron@electronversion@ "${_ASAR}" "$@"
else
- exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
-fi \ No newline at end of file
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
+fi
+exit \ No newline at end of file