summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortioguda2019-09-18 03:25:50 -0300
committertioguda2019-09-18 03:27:22 -0300
commit19a8da18eae50c5d0179f260c79ad98945eb6ae0 (patch)
tree595f088c2284f98aa0000272ae4103711c1f2d86
downloadaur-19a8da18eae50c5d0179f260c79ad98945eb6ae0.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD38
-rw-r--r--softplan-websigner.install35
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1ba8b2a9b00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = softplan-websigner
+ pkgdesc = The Web Signer native application.. An easy solution for using digital certificates in Web applications.
+ pkgver = 2.9.5.1
+ pkgrel = 1
+ url = https://websigner.softplan.com.br
+ install = softplan-websigner.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = desktop-file-utils
+ depends = glib2
+ depends = gtk3>=3.6
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ options = !strip
+ options = !emptydirs
+ options = !upx
+ source_i686 = https://websigner.softplan.com.br/Downloads/2.9.5/webpki-chrome-32-deb
+ sha512sums_i686 = c5d9a30f1a93fa1f75ef10e9632ed6d30b59a19fb1b50dbdd27f6effd6a841f1f903a790a21cdde4f7713dfc745961e0477091f7e321c73f508a5649658ee023
+ source_x86_64 = https://websigner.softplan.com.br/Downloads/2.9.5/webpki-chrome-64-deb
+ sha512sums_x86_64 = a57b50c3f6f8f38282b4b1f9a39f7447c9fd87d4e1da549248e9657c201502cd9db035a3e59e7f3326e46a903ae7f6973e7e084b6fb2f38c3944079cdcd71372
+
+pkgname = softplan-websigner
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a06c5679995d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: tioguda <guda.flavio@gmail.com>
+
+pkgname=softplan-websigner
+_pkgver=2.9.5
+pkgver=${_pkgver}.1
+pkgrel=1
+pkgdesc="The Web Signer native application.. An easy solution for using digital certificates in Web applications."
+arch=('i686' 'x86_64')
+url="https://websigner.softplan.com.br"
+license=('custom')
+depends=('desktop-file-utils' 'glib2' 'gtk3>=3.6' 'hicolor-icon-theme' 'xdg-utils')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_i686=("https://websigner.softplan.com.br/Downloads/${_pkgver}/webpki-chrome-32-deb")
+source_x86_64=("https://websigner.softplan.com.br/Downloads/${_pkgver}/webpki-chrome-64-deb")
+sha512sums_i686=('c5d9a30f1a93fa1f75ef10e9632ed6d30b59a19fb1b50dbdd27f6effd6a841f1f903a790a21cdde4f7713dfc745961e0477091f7e321c73f508a5649658ee023')
+sha512sums_x86_64=('a57b50c3f6f8f38282b4b1f9a39f7447c9fd87d4e1da549248e9657c201502cd9db035a3e59e7f3326e46a903ae7f6973e7e084b6fb2f38c3944079cdcd71372')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ if [[ ${CARCH} == x86_64 ]]; then
+ rm -rf "${pkgdir}"/usr/lib/*; mv "${pkgdir}"/usr/lib64/* "${pkgdir}"/usr/lib; rm -rf "${pkgdir}"/usr/lib64
+ fi
+
+ if [[ ${CARCH} == i686 ]]; then
+ rm -rf "${pkgdir}"/usr/lib64/*
+ fi
+
+ # Archify folder permissions
+ cd ${pkgdir}
+ for d in $(find . -type d); do
+ chmod 755 $d
+ done
+
+}
diff --git a/softplan-websigner.install b/softplan-websigner.install
new file mode 100644
index 000000000000..d7345f900ad1
--- /dev/null
+++ b/softplan-websigner.install
@@ -0,0 +1,35 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Chrome and Chromium uses the manifest file in the /etc dir, which is
+ # checked as an error in Litium package verification.
+ # Thus we are going to move the manifest file after installation.
+
+ # ensure that chrome and chromium extension manifest dir exists
+ CHROME_MANIFEST_DIR=/etc/opt/chrome/native-messaging-hosts/
+ CHROMIUM_MANIFEST_DIR=/etc/chromium/native-messaging-hosts/
+ mkdir -p $CHROME_MANIFEST_DIR
+ mkdir -p $CHROMIUM_MANIFEST_DIR
+
+ # copy manifest to respective dirs
+ cp /opt/softplan-websigner/manifest.json "$CHROME_MANIFEST_DIR"br.com.softplan.webpki.json
+ cp /opt/softplan-websigner/manifest.json "$CHROMIUM_MANIFEST_DIR"br.com.softplan.webpki.json
+
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # remove chromium and chrome manifests
+ CHROME_MANIFEST_DIR=/etc/opt/chrome/native-messaging-hosts/
+ CHROMIUM_MANIFEST_DIR=/etc/chromium/native-messaging-hosts/
+ rm -rf "$CHROME_MANIFEST_DIR"br.com.softplan.webpki.json
+ rm -rf "$CHROMIUM_MANIFEST_DIR"br.com.softplan.webpki.json
+
+ update-desktop-database -q
+}