summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcbpark2019-01-04 16:56:48 +0900
committercbpark2019-01-04 16:56:48 +0900
commitcd0745be33c0f0e3871fc70806b3201dd0a74953 (patch)
treea01673621be6eac14b118133e94306bf8e8a312b
parent8de52cb33f587e5b0e2f64352fb1486f08af060c (diff)
downloadaur-cd0745be33c0f0e3871fc70806b3201dd0a74953.tar.gz
upgpkg: softsusy 4.1.7-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
-rw-r--r--remove_duplicate_header.patch10
3 files changed, 37 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1eb827871224..e380a897f73e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = softsusy
pkgdesc = This program provides a SUSY spectrum in the NMSSM, or the MSSM including flavour violation and with or without R-parity consistent with input Standard Model fermion mass/mixings and electroweak/strong coupling data.
- pkgver = 4.0
+ pkgver = 4.1.7
pkgrel = 1
url = http://softsusy.hepforge.org
- arch = i686
arch = x86_64
license = GPL
+ makedepends = autoconf
+ depends = gcc-libs
depends = gcc-fortran
- depends = looptools
- source = http://www.hepforge.org/archive/softsusy/softsusy-4.0.tar.gz
- sha256sums = 7f9b35e33ab330d279c33e1604a11cfba2a4b7503a2d0197d58de7d4239ec9cf
+ source = http://www.hepforge.org/archive/softsusy/softsusy-4.1.7.tar.gz
+ source = remove_duplicate_header.patch
+ sha256sums = 5ff7890e5be9f0affa89016bf6bcaed032700c09e6ea278a6e7fd5d6d4ccb12c
+ sha256sums = 75923858486bc404f2147b11cb7691410b83be624ca9b2c6607e9dfee98f1353
pkgname = softsusy
diff --git a/PKGBUILD b/PKGBUILD
index 49f298153b0b..5e33f09798e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,38 @@
# Maintainer: Chan Beom Park <cbpark@gmail.com>
pkgname=softsusy
-pkgver=4.0
+pkgver=4.1.7
pkgrel=1
pkgdesc="This program provides a SUSY spectrum in the NMSSM, or the MSSM including flavour violation and with or without R-parity consistent with input Standard Model fermion mass/mixings and electroweak/strong coupling data."
-arch=("i686" "x86_64")
+arch=("x86_64")
url="http://softsusy.hepforge.org"
license=('GPL')
-depends=("gcc-fortran" "looptools")
-source=("http://www.hepforge.org/archive/softsusy/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('7f9b35e33ab330d279c33e1604a11cfba2a4b7503a2d0197d58de7d4239ec9cf')
+makedepends=("autoconf")
+depends=("gcc-libs" "gcc-fortran")
+source=("http://www.hepforge.org/archive/softsusy/${pkgname}-${pkgver}.tar.gz"
+ "remove_duplicate_header.patch")
+sha256sums=('5ff7890e5be9f0affa89016bf6bcaed032700c09e6ea278a6e7fd5d6d4ccb12c'
+ '75923858486bc404f2147b11cb7691410b83be624ca9b2c6607e9dfee98f1353')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ patch -p1 -i "${srcdir}/remove_duplicate_header.patch"
+ autoreconf -i
+}
build() {
cd "${pkgname}-${pkgver}"
- ./configure --enable-looptools --prefix=/usr
+
+ ./configure --prefix=/usr \
+ --enable-shared=yes \
+ --enable-static=no
MAKEFLAGS=-j1 make
}
package() {
cd "${pkgname}-${pkgver}"
+
make DESTDIR="$pkgdir" install
install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
diff --git a/remove_duplicate_header.patch b/remove_duplicate_header.patch
new file mode 100644
index 000000000000..2c14a6762813
--- /dev/null
+++ b/remove_duplicate_header.patch
@@ -0,0 +1,10 @@
+diff -rupN a/src/supermodel/supermodel.amk b/src/supermodel/supermodel.amk
+--- a/src/supermodel/supermodel.amk 2018-07-05 01:13:34.000000000 +0900
++++ b/src/supermodel/supermodel.amk 2019-01-04 16:41:13.311359955 +0900
+@@ -36,5 +36,4 @@ src/supermodel/supermodel/sumo_params.h
+ src/supermodel/supermodel/sumo_smdata.h \
+ src/supermodel/supermodel/sumo_squarks.h \
+ src/supermodel/supermodel/supermodel_defs.h \
+-src/supermodel/supermodel/supermodel.h \
+-src/supermodel/tsil/tsil.h
++src/supermodel/supermodel/supermodel.h