summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeon Spengler2018-10-11 09:36:01 +0200
committerDeon Spengler2018-10-11 09:36:01 +0200
commit01ae1c6038c1e62d06496839744a63b04f9f9350 (patch)
tree37335e08e0f2dca86fced05026b6f91fada08554
parent590648666059a3a8830ce4003bd5da396ad1c4bb (diff)
downloadaur-01ae1c6038c1e62d06496839744a63b04f9f9350.tar.gz
Sogo bugfix-4566
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--sogo-bugfix_4566.patch24
-rw-r--r--ssl_load_error.patch13
4 files changed, 31 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 921d7f157191..d0b1ccd6ad2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sogo
pkgdesc = groupware server built around OpenGroupware.org (OGo) and the SOPE application server
pkgver = 4.0.2
- pkgrel = 3
+ pkgrel = 4
url = http://www.sogo.nu/
install = sogo.install
arch = x86_64
@@ -31,12 +31,12 @@ pkgbase = sogo
source = sogo.service
source = sogo.confd
source = sogo_configure.patch
- source = ssl_load_error.patch
+ source = sogo-bugfix_4566.patch
sha256sums = 35ef20216ff1758a593bed69d8e8e25d23e982a970bf23a3bb2f856f2e5d2f9f
sha256sums = 0720b9ad35a05d86d794c7adbf18277ecde57ed147e96f6105acca93f19d3b8c
sha256sums = 8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7
sha256sums = e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1
- sha256sums = 55934b0763d809b30ac8b597f5c8be32c9226040c5c8d9eff2bb9cc004072c17
+ sha256sums = 5cdac998f1cca5b7d72aa49c25de465354586dfa53f1036ea75bb00e28eff317
pkgname = sogo
diff --git a/PKGBUILD b/PKGBUILD
index fb2591a946b6..1652e98a3286 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=sogo
pkgdesc="groupware server built around OpenGroupware.org (OGo) and the SOPE application server"
pkgver=4.0.2
-pkgrel=3
+pkgrel=4
arch=('x86_64')
url="http://www.sogo.nu/"
license=('GPL')
@@ -35,17 +35,17 @@ source=("http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-${pkgver}.tar.gz"
"sogo.service"
"sogo.confd"
"sogo_configure.patch"
- "ssl_load_error.patch")
+ "sogo-bugfix_4566.patch")
sha256sums=('35ef20216ff1758a593bed69d8e8e25d23e982a970bf23a3bb2f856f2e5d2f9f'
'0720b9ad35a05d86d794c7adbf18277ecde57ed147e96f6105acca93f19d3b8c'
'8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7'
'e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1'
- '55934b0763d809b30ac8b597f5c8be32c9226040c5c8d9eff2bb9cc004072c17')
+ '5cdac998f1cca5b7d72aa49c25de465354586dfa53f1036ea75bb00e28eff317')
prepare() {
cd "$srcdir/SOGo-${pkgver}"
patch configure ../sogo_configure.patch
- patch -Np1 -i ../ssl_load_error.patch
+ patch -Np1 -i ../sogo-bugfix_4566.patch
}
build() {
diff --git a/sogo-bugfix_4566.patch b/sogo-bugfix_4566.patch
new file mode 100644
index 000000000000..4286394ca0dc
--- /dev/null
+++ b/sogo-bugfix_4566.patch
@@ -0,0 +1,24 @@
+diff -Naurp SOGo-4.0.2-orig/UI/MailPartViewers/UIxMailPartSignedViewer.m SOGo-4.0.2/UI/MailPartViewers/UIxMailPartSignedViewer.m
+--- SOGo-4.0.2-orig/UI/MailPartViewers/UIxMailPartSignedViewer.m 2018-10-10 23:32:06.753085278 -0500
++++ SOGo-4.0.2/UI/MailPartViewers/UIxMailPartSignedViewer.m 2018-10-10 23:33:04.864737333 -0500
+@@ -169,10 +169,20 @@
+
+ if (err)
+ {
++# ifdef HAVE_GNUTLS
+ ERR_load_crypto_strings();
+ SSL_load_error_strings();
+ sslError = ERR_reason_error_string(err);
+ validationMessage = [[self labelForKey: [NSString stringWithUTF8String: sslError ? sslError : "(no error information available)"]] retain];
++#elseif (OPENSSL_VERSION < 0x01010001f)
++ ERR_load_crypto_strings();
++ SSL_load_error_strings();
++ sslError = ERR_reason_error_string(err);
++ validationMessage = [[self labelForKey: [NSString stringWithUTF8String: sslError]] retain];
++# else
++ validationMessage = [[self labelForKey: [NSString stringWithUTF8String: sslError]] retain];
++#endif /* HAVE_GNUTLS */
++
+ }
+ }
+
diff --git a/ssl_load_error.patch b/ssl_load_error.patch
deleted file mode 100644
index c56cce845911..000000000000
--- a/ssl_load_error.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- sogo-SOGo-4.0.2/UI/MailPartViewers/UIxMailPartSignedViewer.m 2018-08-24 15:01:47.000000000 +0200
-+++ sogo-SOGo-4.0.1/UI/MailPartViewers/UIxMailPartSignedViewer.m 2018-07-10 15:51:12.000000000 +0200
-@@ -170,9 +170,8 @@
- if (err)
- {
- ERR_load_crypto_strings();
-- SSL_load_error_strings();
- sslError = ERR_reason_error_string(err);
-- validationMessage = [[self labelForKey: [NSString stringWithUTF8String: sslError ? sslError : "(no error information available)"]] retain];
-+ validationMessage = [[self labelForKey: [NSString stringWithUTF8String: sslError]] retain];
- }
- }
-